低危 ISC BIND拒绝服务

CVE编号

CVE-2017-3135

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-17
漏洞描述
当使用DNS64和RPZ时,BIND处理查询响应的方式中发现了拒绝服务缺陷。远程攻击者可以通过特制的DNS响应使用此缺陷意外地通过断言失败或空指针取消引用来make named exit 。

解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
http://www.isc.org/downloads
https://kb.isc.org/article/AA-01453
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind 9.10.0 -
运行在以下环境
应用 isc bind 9.10.4 -
运行在以下环境
应用 isc bind 9.10.5 -
运行在以下环境
应用 isc bind 9.11.0 -
运行在以下环境
应用 isc bind 9.11.1 -
运行在以下环境
应用 isc bind 9.9.10 -
运行在以下环境
应用 isc bind 9.9.3 -
运行在以下环境
应用 isc bind 9.9.8 -
运行在以下环境
应用 isc bind 9.9.9 -
运行在以下环境
应用 netapp data_ontap_edge - -
运行在以下环境
应用 netapp element_software_management_node - -
运行在以下环境
系统 alpine_3.2 bind * Up to
(excluding)
9.10.4_p6-r0
运行在以下环境
系统 alpine_3.3 bind * Up to
(excluding)
9.10.4_p6-r0
运行在以下环境
系统 alpine_3.4 bind * Up to
(excluding)
9.10.4_p6-r0
运行在以下环境
系统 alpine_3.5 bind * Up to
(excluding)
9.10.4_p6-r0
运行在以下环境
系统 centos_7 bind * Up to
(excluding)
9.9.4-38.el7_3.2
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:9.10.3.dfsg.P4-12
运行在以下环境
系统 debian_7 bind * Up to
(excluding)
1:9.8.4.dfsg.P1-6+nmu2+deb7u15
运行在以下环境
系统 debian_8 bind * Up to
(excluding)
1:9.9.5.dfsg-9+deb8u1
运行在以下环境
系统 fedora_24 bind * Up to
(excluding)
9.9.9-4.P6.fc24
运行在以下环境
系统 fedora_25 bind * Up to
(excluding)
9.9.9-4.P6.fc25
运行在以下环境
系统 opensuse_Leap_42.1 bind * Up to
(excluding)
9.9.9P1-46.1
运行在以下环境
系统 opensuse_Leap_42.2 bind * Up to
(excluding)
9.9.9P1-46.1
运行在以下环境
系统 oracle_7 bind * Up to
(excluding)
9.9.4-38.el7_3.2
运行在以下环境
系统 redhat_7 bind * Up to
(excluding)
32:9.9.4-38.el7_3.2
运行在以下环境
系统 suse_11_SP4 bind * Up to
(excluding)
9.9.6P1-0.39.1
运行在以下环境
系统 suse_12 bind * Up to
(excluding)
9.9.9P1-62
运行在以下环境
系统 suse_12_SP1 bind * Up to
(excluding)
9.9.9P1-56.1
运行在以下环境
系统 suse_12_SP2 bind * Up to
(excluding)
9.9.9P1-56.1
运行在以下环境
系统 ubuntu_12.04.5_lts bind9 * Up to
(excluding)
1:9.8.1.dfsg.P1-4ubuntu0.21
运行在以下环境
系统 ubuntu_14.04 bind * Up to
(excluding)
1:9.9.5.dfsg-3ubuntu0.13
运行在以下环境
系统 ubuntu_14.04.6_lts bind9 * Up to
(excluding)
1:9.9.5.dfsg-3ubuntu0.13
运行在以下环境
系统 ubuntu_16.04 bind * Up to
(excluding)
1:9.10.3.dfsg.P4-8ubuntu1.5
运行在以下环境
系统 ubuntu_16.04.7_lts bind9 * Up to
(excluding)
1:9.10.3.dfsg.P4-8ubuntu1.5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况