低危 ISC BIND up to 9.12.0rc1 Cleanup Assertion 拒绝服务漏洞

CVE编号

CVE-2017-3145

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-17 09:29:00
漏洞描述
在绑定在上游递归获取上下文上的绑定内部处理清理操作的方式中,发现了导致拒绝服务的使用后无缺陷。远程攻击者可能会利用此缺陷使命名(充当DNSSEC验证解析器)通过巧尽心思构建的DNS请求导致断言失败意外退出。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://kb.isc.org/article/AA-01542
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind * From
(including)
9.4.0
Up to
(including)
9.8.8
运行在以下环境
应用 isc bind * From
(including)
9.9.0
Up to
(including)
9.9.11
运行在以下环境
应用 isc bind 9.9.3 s1 -
运行在以下环境
应用 isc bind 9.9.11 s1 -
运行在以下环境
应用 isc bind * From
(including)
9.10.0
Up to
(including)
9.10.6
运行在以下环境
应用 isc bind 9.10.5 s1 -
运行在以下环境
应用 isc bind 9.10.6 s1 -
运行在以下环境
应用 isc bind * From
(including)
9.11.0
Up to
(including)
9.11.2
运行在以下环境
应用 isc bind 9.12.0 alpha1 -
运行在以下环境
应用 isc bind 9.12.0 b1 -
运行在以下环境
应用 isc bind 9.12.0 b2 -
运行在以下环境
应用 isc bind 9.12.0 rc1 -
2
运行在以下环境
应用 netapp data_ontap_edge - -
3
运行在以下环境
系统 alpine_3.9 bind * Up to
(excluding)
9.11.2_p1-r0
4
运行在以下环境
系统 alpine_3.13 bind * Up to
(excluding)
9.11.2_p1-r0
5
运行在以下环境
系统 amazon_AMI bind * Up to
(excluding)
9.8.2-0.62.rc1.57.amzn1
6
运行在以下环境
系统 alpine_3.11 bind * Up to
(excluding)
9.11.2_p1-r0
7
运行在以下环境
系统 alpine_3.4 bind * Up to
(excluding)
9.10.6_p1-r0
8
运行在以下环境
系统 amazon_2 bind * Up to
(excluding)
9.9.4-51.amzn2.2
9
运行在以下环境
系统 alpine_3.5 bind * Up to
(excluding)
9.10.6_p1-r0
10
运行在以下环境
系统 alpine_3.7 bind * Up to
(excluding)
9.11.2_p1-r0
11
运行在以下环境
系统 alpine_3.12 bind * Up to
(excluding)
9.11.2_p1-r0
12
运行在以下环境
系统 alpine_3.10 bind * Up to
(excluding)
9.11.2_p1-r0
13
运行在以下环境
系统 alpine_3.8 bind * Up to
(excluding)
9.11.2_p1-r0
14
运行在以下环境
系统 alpine_edge bind * Up to
(excluding)
9.11.2_p1-r0
15
运行在以下环境
系统 alpine_3.6 bind * Up to
(excluding)
9.11.2_p1-r0
16
运行在以下环境
系统 debian_7 bind * Up to
(excluding)
1:9.8.1.dfsg.P1-4.4
17
运行在以下环境
系统 debian_8 bind * Up to
(excluding)
1:9.9.5.dfsg-9+deb8u5
18
运行在以下环境
系统 debian_9 bind * Up to
(excluding)
9.10.3.dfsg.P4-12.3+deb9u7
19
运行在以下环境
系统 suse_12_SP2 bind * Up to
(excluding)
9.9.9P1-63.7.1
20
运行在以下环境
系统 suse_12_SP3 bind * Up to
(excluding)
9.9.9P1-63.7.1
21
运行在以下环境
系统 oracle_6 bind * Up to
(excluding)
9.8.2-0.62.rc1.el6_9.5
22
运行在以下环境
系统 centos_6 bind * Up to
(excluding)
9.8.2-0.62.rc1.el6_9.5
23
运行在以下环境
系统 suse_11_SP4 bind * Up to
(excluding)
9.9.6P1-0.51.7.1
24
运行在以下环境
系统 opensuse_Leap_42.3 bind * Up to
(excluding)
9.9.9P1-53.1
25
运行在以下环境
系统 centos_7 bind * Up to
(excluding)
9.9.4-51.el7_4.2
26
运行在以下环境
系统 fedora_27 bind * Up to
(excluding)
9.11.2-1.P1.fc27
27
运行在以下环境
系统 fedora_26 bind * Up to
(excluding)
9.11.2-1.P1.fc26
28
运行在以下环境
系统 oracle_7 bind * Up to
(excluding)
9.9.4-51.el7_4.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况