低危 OpenSSL安全限制绕过漏洞

CVE编号

CVE-2017-3737

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-08 05:29:00
漏洞描述
OpenSSL 1.0.2(从版本1.0.2b开始)引入了“错误状态”机制。其目的是,如果在握手过程中发生了致命错误,那么OpenSSL将进入错误状态,如果您试图继续握手,则会立即失败。这是为显式握手函数(SSL_do_handshake()、SSL_accept()和SSL_connect())设计的,但是由于一个bug,如果直接调用SSL_read()或SSL_write(),它就不能正常工作。在这种情况下,如果握手失败,那么在初始函数调用中将返回一个致命错误。如果应用程序随后为相同的SSL对象调用SSL_read()/SSL_write(),则该方法将成功,并且无需从SSL/TLS记录层直接解密/加密数据。为了利用这个问题,必须存在一个应用程序错误,导致在已经收到致命错误之后发出对SSL_read()/SSL_write()的调用。OpenSSL版本1.0.2b-1.0.2m受到影响。已修复OpenSSL 1.0.2n。OpenSSL 1.1.0不受影响。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://openssl.org/https://www.openssl.org/news/secadv/20171207.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl 1.0.2b -
运行在以下环境
应用 openssl openssl 1.0.2c -
运行在以下环境
应用 openssl openssl 1.0.2d -
运行在以下环境
应用 openssl openssl 1.0.2e -
运行在以下环境
应用 openssl openssl 1.0.2f -
运行在以下环境
应用 openssl openssl 1.0.2g -
运行在以下环境
应用 openssl openssl 1.0.2h -
运行在以下环境
应用 openssl openssl 1.0.2i -
运行在以下环境
应用 openssl openssl 1.0.2j -
运行在以下环境
应用 openssl openssl 1.0.2k -
运行在以下环境
应用 openssl openssl 1.0.2l -
运行在以下环境
应用 openssl openssl 1.0.2m -
2
运行在以下环境
系统 amazon_AMI openssl * Up to
(excluding)
1.0.2k-12.109.amzn1
3
运行在以下环境
系统 alpine_3.6 openssl * Up to
(excluding)
1.0.2n-r0
4
运行在以下环境
系统 amazon_2 openssl * Up to
(excluding)
1.0.2k-12.amzn2.0.1
5
运行在以下环境
系统 alpine_3.4 openssl * Up to
(excluding)
1.0.2n-r0
6
运行在以下环境
系统 alpine_3.3 openssl * Up to
(excluding)
1.0.2n-r0
7
运行在以下环境
系统 alpine_3.5 openssl * Up to
(excluding)
1.0.2n-r0
8
运行在以下环境
系统 alpine_3.8 openssl * Up to
(excluding)
1.0.2n-r0
9
运行在以下环境
系统 alpine_3.7 openssl * Up to
(excluding)
1.0.2n-r0
10
运行在以下环境
系统 debian_9 openssl * Up to
(excluding)
1.0.2l-2+deb9u3
11
运行在以下环境
系统 suse_12_SP2 openssl * Up to
(excluding)
1.0.2j-60.20.2
12
运行在以下环境
系统 suse_12_SP3 openssl * Up to
(excluding)
1.0.2j-60.20.2
13
运行在以下环境
系统 oracle_7 openssl * Up to
(excluding)
1.0.2k-16.0.1.ksplice1.el7_6.1
14
运行在以下环境
系统 opensuse_Leap_42.3 openssl * Up to
(excluding)
1.0.2j-16.1
15
运行在以下环境
系统 opensuse_Leap_42.2 openssl * Up to
(excluding)
1.0.2j-16.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
CWE-787 跨界内存写
阿里云安全产品覆盖情况