低危 ImageMagick本地内存破坏漏洞

CVE编号

CVE-2017-5506

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-25
漏洞描述
ImageMagick是一个免费的创建、编辑、合成图片的软件。ImageMagick的大多数功能的使用都来源于命令行工具。

Imagemagick存在本地内存破坏漏洞。攻击者利用该漏洞在受影响的应用程序中执行任意代码。失败的攻击会造成拒绝服务漏洞。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851383
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
8:6.9.7.4+dfsg-1
运行在以下环境
系统 debian_7 imagemagick * Up to
(excluding)
8:6.7.7.10-5+deb7u11
运行在以下环境
系统 debian_8 imagemagick * Up to
(excluding)
8:6.8.9.9-5+deb8u2
运行在以下环境
系统 fedora_25 imagemagick * Up to
(excluding)
7.0.6-9.2.fc25
运行在以下环境
系统 fedora_26 imagemagick * Up to
(excluding)
7.0.6-9.2.fc26
运行在以下环境
系统 opensuse_Leap_42.1 imagemagick * Up to
(excluding)
6.8.8.1-28.1
运行在以下环境
系统 opensuse_Leap_42.2 imagemagick * Up to
(excluding)
6.8.8.1-28.1
运行在以下环境
系统 suse_11_SP4 imagemagick * Up to
(excluding)
6.4.3.6-7.65.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-70
运行在以下环境
系统 suse_12_SP1 imagemagick * Up to
(excluding)
1-6.8.8.1-59.1
运行在以下环境
系统 suse_12_SP2 imagemagick * Up to
(excluding)
1-6.8.8.1-59.1
运行在以下环境
系统 ubuntu_12.04.5_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.8
运行在以下环境
系统 ubuntu_14.04.6_lts imagemagick * Up to
(excluding)
8:6.7.7.10-6ubuntu3.5
运行在以下环境
系统 ubuntu_16.04 ImageMagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.5
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.5
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-415 双重释放
阿里云安全产品覆盖情况