低危 Oracle API Gateway 11.1.2.4.0 Apache Batik xml 外部实体引用漏洞

CVE编号

CVE-2017-5662

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-04-19
漏洞描述
Apache Batik是一个纯Java库,可用于渲染、生成及操纵SVG图形。

Apache Batik XXE存在信息泄露漏洞。在Apache Batik中,位于使用batik的服务器的文件系统上的文件可被泄露给发送恶意形成的SVG文件的任意用户。可以显示的文件类型取决于可以利用的应用程序正在运行的用户上下文。如果用户是root用户,则可能会对服务器(包括机密或敏感文件)造成完全的危害。还可使用XXE通过拒绝服务攻击服务器的可用性,因为xml文档中的引用可能触发放大攻击。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://xmlgraphics.apache.org/security.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache batik * Up to
(including)
1.8
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_7 batik * Up to
(excluding)
1.7+dfsg-3+deb7u2
运行在以下环境
系统 debian_8 batik * Up to
(excluding)
1.7+dfsg-5+deb8u1
运行在以下环境
系统 debian_9 batik * Up to
(excluding)
1.8-4+deb9u1
运行在以下环境
系统 fedora_24 batik * Up to
(excluding)
1.8-9.fc24
运行在以下环境
系统 fedora_25 batik * Up to
(excluding)
1.8-9.fc25
运行在以下环境
系统 fedora_26 batik * Up to
(excluding)
1.9-3.fc26
运行在以下环境
系统 ubuntu_14.04.6_lts batik * Up to
(excluding)
1.7.ubuntu-8ubuntu2.14.04.2
运行在以下环境
系统 ubuntu_18.04.5_lts batik * Up to
(excluding)
1.9-3
运行在以下环境
系统 ubuntu_18.10 batik * Up to
(excluding)
1.9-3
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-611 XML外部实体引用的不恰当限制(XXE)
阿里云安全产品覆盖情况