低危 Vim缓冲区溢出漏洞

CVE编号

CVE-2017-5953

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-02-10
漏洞描述
Vim是一款开源的、可配置的用于创建和更改任何类型文本的文本编辑器,它可在大多数UNIX和AppleOSX中使用。

Vim patch 8.0.0322之前的版本中存在缓冲区溢出漏洞,该漏洞源于在处理spell文件时程序未能正确的验证树的长度值。攻击者可利用该漏洞造成整数溢出和缓冲区溢出。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(including)
8.0.0055
运行在以下环境
系统 alpine_3.10 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.11 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.2 vim * Up to
(excluding)
7.4.712-r2
运行在以下环境
系统 alpine_3.3 vim * Up to
(excluding)
7.4.943-r5
运行在以下环境
系统 alpine_3.4 vim * Up to
(excluding)
7.4.1831-r3
运行在以下环境
系统 alpine_3.5 vim * Up to
(excluding)
8.0.0329-r0
运行在以下环境
系统 alpine_3.6 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.7 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.8 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_3.9 vim * Up to
(excluding)
0.2.0-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.0.0329-r0
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.0.0503-1.45.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2:8.0.0197-2
运行在以下环境
系统 debian_7 vim * Up to
(excluding)
2:7.3.547-7+deb7u2
运行在以下环境
系统 debian_8 vim * Up to
(excluding)
2:7.4.488-7+deb8u2
运行在以下环境
系统 fedora_24 vim * Up to
(excluding)
8.0.324-1.fc24
运行在以下环境
系统 fedora_25 vim * Up to
(excluding)
8.0.324-1.fc25
运行在以下环境
系统 opensuse_Leap_42.1 vim * Up to
(excluding)
7.4.326-11.1
运行在以下环境
系统 opensuse_Leap_42.2 vim * Up to
(excluding)
7.4.326-10.3.1
运行在以下环境
系统 suse_11_SP4 vim * Up to
(excluding)
7.2-8.20.8
运行在以下环境
系统 suse_12 gvim * Up to
(excluding)
7.4.326-16
运行在以下环境
系统 suse_12_SP2 vim * Up to
(excluding)
7.4.326-16.1
运行在以下环境
系统 ubuntu_14.04 vim * Up to
(excluding)
2:7.4.052-1ubuntu3.1+esm1
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.3
运行在以下环境
系统 ubuntu_16.04.7_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.3
运行在以下环境
系统 ubuntu_18.04 vim * Up to
(excluding)
0.2.2-3
运行在以下环境
系统 ubuntu_18.04.5_lts vim * Up to
(excluding)
2:8.0.1144-1ubuntu1
运行在以下环境
系统 ubuntu_18.10 vim * Up to
(excluding)
2:8.0.1144-1ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况