低危 Libmspack 缓冲区溢出拒绝服务

CVE编号

CVE-2017-6419

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-07
漏洞描述
libmspack 0.5alpha中的mspack / lzxd.c,如ClamAV 0.99.2中所使用,允许远程攻击者导致拒绝服务(基于堆的缓冲区溢出和应用程序崩溃),或者可能通过精心设计的CHM文件产生未指定的其他影响。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/vrtadmin/clamav-devel/commit/a83773682e856ad6529ba6db8d1792e6d515d7f1
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 clamav clamav 0.99.2 -
运行在以下环境
应用 libmspack_project libmspack 0.5 -
运行在以下环境
系统 alpine_3.10 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.11 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.12 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.13 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.14 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.15 clamav * Up to
(excluding)
0.99.4-r0
运行在以下环境
系统 alpine_3.3 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.4 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.5 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.6 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.7 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.8 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_3.9 clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 alpine_edge clamav * Up to
(excluding)
0.5_alpha-r1
运行在以下环境
系统 amazon_AMI clamav * Up to
(excluding)
0.99.3-1.28.amzn1
运行在以下环境
系统 debian_7 clamav * Up to
(excluding)
0.99.2+dfsg-0+deb7u5
运行在以下环境
系统 debian_8 clamav * Up to
(excluding)
0.5-1+deb8u3
运行在以下环境
系统 debian_9 clamav * Up to
(excluding)
0.99.4+dfsg-1+deb9u1
运行在以下环境
系统 fedora_25 clamav * Up to
(excluding)
0.6-0.1.alpha.fc25
运行在以下环境
系统 fedora_26 clamav * Up to
(excluding)
0.6-0.1.alpha.fc26
运行在以下环境
系统 fedora_27 clamav * Up to
(excluding)
0.6-0.1.alpha.fc27
运行在以下环境
系统 fedora_EPEL_6 clamav * Up to
(excluding)
0.6-0.1.alpha.el6
运行在以下环境
系统 fedora_EPEL_7 clamav * Up to
(excluding)
0.6-0.1.alpha.el7
运行在以下环境
系统 opensuse_Leap_42.3 clamav * Up to
(excluding)
0.99.3-20.1
运行在以下环境
系统 suse_11_SP4 clamav * Up to
(excluding)
0.99.3-0.20.3.2
运行在以下环境
系统 suse_12_SP2 clamav * Up to
(excluding)
0.99.4-33.9.1
运行在以下环境
系统 suse_12_SP3 clamav * Up to
(excluding)
0.99.4-33.9.1
运行在以下环境
系统 ubuntu_14.04 clamav * Up to
(excluding)
0.99.2+addedllvm-0ubuntu0.14.04.2
运行在以下环境
系统 ubuntu_16.04 clamav * Up to
(excluding)
0.5-1ubuntu0.16.04.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况