低危 audiofile堆溢出漏洞

CVE编号

CVE-2017-6827

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-16
漏洞描述
audiofile是一个用于读写音频文件的处理库。

audiofile的MSADPCM.cpp文件的‘MSADPCM::initializeCoefficients’函数存在堆缓冲区溢出漏洞。远程攻击者可利用漏洞构建特殊的音频文件,诱使应用解析,可使应用程序崩溃。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://podofo.sourceforge.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 audiofile audiofile 0.3.6 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0.3.6-4
运行在以下环境
系统 debian_7 audiofile * Up to
(excluding)
0.3.4-2+deb7u1
运行在以下环境
系统 debian_8 audiofile * Up to
(excluding)
0.3.6-2+deb8u2
运行在以下环境
系统 opensuse_Leap_42.1 audiofile * Up to
(excluding)
0.3.6-10.3.1
运行在以下环境
系统 opensuse_Leap_42.2 audiofile * Up to
(excluding)
0.3.6-10.3.1
运行在以下环境
系统 oracle_7 audiofile * Up to
(excluding)
0.3.6-9.el7
运行在以下环境
系统 suse_11_SP4 audiofile * Up to
(excluding)
0.2.6-142.17.1
运行在以下环境
系统 suse_12 audiofile * Up to
(excluding)
0.3.6-10
运行在以下环境
系统 suse_12_SP1 audiofile * Up to
(excluding)
0.3.6-10.1
运行在以下环境
系统 suse_12_SP2 audiofile * Up to
(excluding)
0.3.6-10.1
运行在以下环境
系统 ubuntu_12.04.5_lts audiofile * Up to
(excluding)
0.3.3-2ubuntu0.3
运行在以下环境
系统 ubuntu_14.04 audiofile * Up to
(excluding)
0.3.6-2ubuntu0.14.04.2
运行在以下环境
系统 ubuntu_14.04.6_lts audiofile * Up to
(excluding)
0.3.6-2ubuntu0.14.04.2
运行在以下环境
系统 ubuntu_16.04 audiofile * Up to
(excluding)
0.3.6-2ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts audiofile * Up to
(excluding)
0.3.6-2ubuntu0.16.04.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况