低危 apng2gif 1.7 PNG File read_chunk 拒绝服务漏洞

CVE编号

CVE-2017-6961

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-17
漏洞描述
apng2gif是一套用来将APNG动画转成GIF动画的工具。

apng2gif 1.7版本中的read_chunk函数存在安全漏洞,该漏洞源于程序未能正确的过滤用户提交的输入。攻击者可利用该漏洞导致拒绝服务(崩溃)。
解决建议
目前没有详细的解决方案提供:
http://apng2gif.sourceforge.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apng2gif_project apng2gif 1.7 -
运行在以下环境
系统 debian_9 apng2gif * Up to
(excluding)
1.7-1
运行在以下环境
系统 ubuntu_20.04 apng2gif * Up to
(excluding)
1.8-0.1
运行在以下环境
系统 ubuntu_21.04 apng2gif * Up to
(excluding)
1.8-0.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况