低危 PHP 输入验证错误漏洞

CVE编号

CVE-2017-7189

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-11
漏洞描述
2017-03-07之前的PHP7.x中的main/streams/xp_socket.c错误地处理了fsockopen调用,例如通过解释fsockopen('127.0.0.1:80',443),就好像地址/端口是127.0.0.1:443,后来被截断为127.0.0.1:80。如果显式提供的端口号(在本例中为443)作为安全策略硬编码到应用程序中,但主机名参数(在本例中为127.0.0.1:80)是从不受信任的输入中获取的,则此行为存在安全风险。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * From
(including)
7.0.0
Up to
(excluding)
7.0.16
运行在以下环境
系统 debian_10 php7.0 * Up to
(including)
7.3.31-1~deb10u1
运行在以下环境
系统 debian_9 php7.0 * Up to
(including)
7.0.33-0+deb9u8
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况