低危 缓存溢出编码执行

CVE编号

CVE-2017-7376

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-20
漏洞描述
libxml2中的缓冲区溢出允许远程攻击者在处理重定向时利用不正确的端口值限制来执行任意代码。&nbsp;<br />
&nbsp;

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://source.android.com/security/bulletin/2017-06-01
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xmlsoft libxml2 * Up to
(excluding)
2.9.5
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_7 libxml2 * Up to
(excluding)
2.8.0+dfsg1-7+wheezy9
运行在以下环境
系统 debian_8 libxml2 * Up to
(excluding)
2.9.1+dfsg1-5+deb8u4
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u1
运行在以下环境
系统 opensuse_Leap_42.2 libxml2 * Up to
(excluding)
2.9.4-5.10.1
运行在以下环境
系统 suse_11_SP4 libxml2 * Up to
(excluding)
2.7.6-0.76.4
运行在以下环境
系统 suse_12 sles12sp2-docker-image * Up to
(excluding)
1.0.2-20180821
运行在以下环境
系统 ubuntu_14.04 libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.10
运行在以下环境
系统 ubuntu_14.04.6_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.10
运行在以下环境
系统 ubuntu_16.04 libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.3
运行在以下环境
系统 ubuntu_16.04.7_lts libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况