中危 apt-cacher和apt-cacher-ng HTTP响应拆分漏洞

CVE编号

CVE-2017-7443

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-04-06
漏洞描述
apt-cacher是一套用来缓冲debian软件包的软件。apt-cacher-ng是一个用于Linux系统的HTTP协议代理。

apt-cacher 1.7.15之前的版本和apt-cacher-ng 3.4之前的版本中存在HTTP响应拆分漏洞。攻击者可利用该漏洞注入HTTP头。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=858739
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apt-cacher-ng_project apt-cacher-ng * Up to
(including)
3.3
运行在以下环境
应用 apt-cacher_project apt-cacher * Up to
(including)
1.7.13
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.7.13+deb9u1
运行在以下环境
系统 debian_10 apt-cacher * Up to
(excluding)
1.7.13+deb9u1
运行在以下环境
系统 debian_7 apt-cacher * Up to
(excluding)
1.7.6+deb7u1
运行在以下环境
系统 debian_8 apt-cacher * Up to
(excluding)
1.7.10+deb8u1
运行在以下环境
系统 debian_9 apt-cacher * Up to
(excluding)
1.7.13+deb9u1
运行在以下环境
系统 ubuntu_18.04.5_lts apt-cacher * Up to
(excluding)
1.7.15
运行在以下环境
系统 ubuntu_18.10 apt-cacher * Up to
(excluding)
1.7.15
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-113 HTTP头部中CRLF序列转义处理不恰当(HTTP响应分割)
阿里云安全产品覆盖情况