低危 控制节点上的任意代码执行

CVE编号

CVE-2017-7466

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-23
漏洞描述
版本2.3之前的Ansible在处理从客户端系统发送的数据时存在输入验证漏洞。控制由Ansible管理的客户端系统并能够将事实发送回Ansible服务器的攻击者可以利用此漏洞使用Ansible服务器权限在Ansible服务器上执行任意代码。 

解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://www.ansible.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(excluding)
2.3
运行在以下环境
应用 redhat openstack 10.0 -
运行在以下环境
应用 redhat openstack 11.0 -
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.3.0.0-1.fc24
运行在以下环境
系统 fedora_24 ansible-doc * Up to
(excluding)
2.3.0.0-1.fc24
运行在以下环境
系统 fedora_25 ansible * Up to
(excluding)
2.3.0.0-1.fc25
运行在以下环境
系统 fedora_25 ansible-doc * Up to
(excluding)
2.3.0.0-1.fc25
运行在以下环境
系统 fedora_26 ansible * Up to
(excluding)
2.3.0.0-1.fc26
运行在以下环境
系统 fedora_26 ansible-doc * Up to
(excluding)
2.3.0.0-1.fc26
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.3.0.0-1.el6
运行在以下环境
系统 fedora_EPEL_6 ansible-doc * Up to
(excluding)
2.3.0.0-1.el6
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.3.0.0-1.el7
运行在以下环境
系统 fedora_EPEL_7 ansible-doc * Up to
(excluding)
2.3.0.0-1.el7
运行在以下环境
系统 ubuntu_16.04 ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况