低危 Ansible安全绕过漏洞(CNVD-2017-10573)

CVE编号

CVE-2017-7481

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-20
漏洞描述
Ansible是一款计算机系统配置管理器,它可用于发布、管理和编排计算机系统。

Ansible存在安全绕过漏洞。攻击者可利用此漏洞绕过安全限制并执行未授权的操作。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://bugzilla.redhat.com/show_bug.cgi?id=1450018
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * Up to
(excluding)
2.3.1.0
运行在以下环境
应用 redhat ansible_engine 2.4.0.0 -
运行在以下环境
应用 redhat gluster_storage 3.2 -
运行在以下环境
应用 redhat openshift_container_platform 3.2 -
运行在以下环境
应用 redhat openshift_container_platform 3.3 -
运行在以下环境
应用 redhat openshift_container_platform 3.4 -
运行在以下环境
应用 redhat openshift_container_platform 3.5 -
运行在以下环境
应用 redhat openstack 10.0 -
运行在以下环境
应用 redhat openstack 11.0 -
运行在以下环境
应用 redhat virtualization 4.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u2
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.3.1.0-1.fc24
运行在以下环境
系统 fedora_25 ansible * Up to
(excluding)
2.3.1.0-1.fc25
运行在以下环境
系统 fedora_26 ansible * Up to
(excluding)
2.3.1.0-1.fc26
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.3.1.0-1.el6
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.3.1.0-1.el7
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
运行在以下环境
系统 suse_11 ansible * Up to
(excluding)
2.2.0.0-10
运行在以下环境
系统 ubuntu_16.04 ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.3
运行在以下环境
系统 ubuntu_16.04.7_lts ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.3
运行在以下环境
系统 ubuntu_18.04.5_lts ansible * Up to
(excluding)
2.5.1+dfsg-1
运行在以下环境
系统 ubuntu_18.10 ansible * Up to
(excluding)
2.6.1+dfsg-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况