低危 默认情况下启用带有硬编码密钥的模拟CMC身份验证插件

CVE编号

CVE-2017-7537

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-27
漏洞描述
结果发现,默认情况下,在10.6.4之前的pki-core软件包中意外启用了带有硬编码密钥的模拟CMC身份验证插件。攻击者可能会利用此漏洞绕过常规身份验证过程并欺骗CA服务器颁发证书。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 dogtagpki dogtagpki * Up to
(excluding)
10.6.4
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 oracle linux_7 pki-base * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-base-java * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-ca * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-javadoc * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-kra * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-server * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-symkey * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle linux_7 pki-tools * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 oracle_7 pki-server * Up to
(excluding)
10.4.1-11.el7
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 pki-base * Up to
(excluding)
0:10.4.1-11.el7
运行在以下环境
系统 ubuntu_18.04.5_lts dogtag-pki * Up to
(excluding)
10.6.0-1ubuntu2
运行在以下环境
系统 ubuntu_18.04_lts dogtag-pki * Up to
(excluding)
10.6.0-1ubuntu2
运行在以下环境
系统 ubuntu_18.10 dogtag-pki * Up to
(excluding)
10.6.0-1ubuntu2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-798 使用硬编码的凭证
阿里云安全产品覆盖情况