低危 Augeas堆缓冲区溢出漏洞

CVE编号

CVE-2017-7555

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-18
漏洞描述
由于对转义字符串的处理不当,版本至1.8.0(含)的Augeas版本容易遭受基于堆的缓冲区溢出。攻击者可能发送精心制作的字符串,这将导致使用augeas的应用程序复制缓冲区的末尾,从而导致崩溃或可能的代码执行。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://github.com/hercules-team/augeas/pull/480
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 augeas augeas * Up to
(including)
1.8.0
运行在以下环境
系统 alpine_3.3 augeas * Up to
(excluding)
1.4.0-r5
运行在以下环境
系统 alpine_3.4 augeas * Up to
(excluding)
1.5.0-r1
运行在以下环境
系统 alpine_3.5 augeas * Up to
(excluding)
1.6.0-r1
运行在以下环境
系统 alpine_3.6 augeas * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 centos_7 augeas * Up to
(excluding)
1.4.0-2.el7_4.1
运行在以下环境
系统 debian_7 augeas * Up to
(excluding)
0.10.0-1+deb7u1
运行在以下环境
系统 debian_8 augeas * Up to
(excluding)
1.2.0-0.2+deb8u2
运行在以下环境
系统 debian_9 augeas * Up to
(excluding)
1.8.0-1+deb9u1
运行在以下环境
系统 fedora_25 augeas * Up to
(excluding)
1.8.1-1.fc25
运行在以下环境
系统 fedora_26 augeas * Up to
(excluding)
1.8.1-1.fc26
运行在以下环境
系统 oracle_7 augeas * Up to
(excluding)
1.4.0-2.el7_4.1
运行在以下环境
系统 redhat_7 augeas * Up to
(excluding)
0:1.4.0-2.el7_4.1
运行在以下环境
系统 suse_11_SP4 augeas * Up to
(excluding)
0.9.0-3.21.3.1
运行在以下环境
系统 suse_12 augeas * Up to
(excluding)
1.2.0-12.3
运行在以下环境
系统 suse_12_SP2 augeas * Up to
(excluding)
1.2.0-12.3.1
运行在以下环境
系统 suse_12_SP3 augeas * Up to
(excluding)
1.2.0-17.3.1
运行在以下环境
系统 ubuntu_14.04 augeas * Up to
(excluding)
1.2.0-0ubuntu1.3
运行在以下环境
系统 ubuntu_14.04.6_lts augeas * Up to
(excluding)
1.2.0-0ubuntu1.3
运行在以下环境
系统 ubuntu_16.04 augeas * Up to
(excluding)
1.4.0-0ubuntu1.1
运行在以下环境
系统 ubuntu_16.04.7_lts augeas * Up to
(excluding)
1.4.0-0ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况