低危 GNU binutils 2.28 BFD Library elflink.c main File Descriptor 拒绝服务漏洞

CVE编号

CVE-2017-7614

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-04-10 03:59:00
漏洞描述
GNU Binutils(又名GNU Binary Utilities或binutils)是GNU计划开发的一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。
GNU Binutils 2.28版本中发布的Binary File Descriptor (BFD)库的elflink.c文件存在安全漏洞。远程攻击者可借助‘int main() {return 0;}’程序利用该漏洞造成拒绝服务(应用程序崩溃)。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://blogs.gentoo.org/ago/2017/04/05/binutils-two-null-pointer-dereference-in-elflink-c/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils 2.28 -
2
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
3
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
4
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
5
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
6
运行在以下环境
系统 opensuse_Leap_42.2 binutils * Up to
(excluding)
2.29.1-13.1
7
运行在以下环境
系统 opensuse_Leap_42.3 binutils * Up to
(excluding)
2.29.1-13.1
8
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
9
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
10
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
11
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
12
运行在以下环境
系统 ubuntu_16.04 binutils * Up to
(excluding)
2.26.1-1ubuntu1~16.04.8+esm1
13
运行在以下环境
系统 alpine_3.14 binutils * Up to
(excluding)
2.28-r1
14
运行在以下环境
系统 opensuse_Leap_42.2 binutils * Up to
(excluding)
2.29.1-13.1
15
运行在以下环境
系统 opensuse_Leap_42.3 binutils * Up to
(excluding)
2.29.1-13.1
16
运行在以下环境
系统 alpine_3.6 binutils * Up to
(excluding)
2.28-r1
17
运行在以下环境
系统 alpine_3.12 binutils * Up to
(excluding)
2.28-r1
18
运行在以下环境
系统 alpine_3.11 binutils * Up to
(excluding)
2.28-r1
19
运行在以下环境
系统 alpine_3.9 binutils * Up to
(excluding)
2.28-r1
20
运行在以下环境
系统 alpine_3.13 binutils * Up to
(excluding)
2.28-r1
21
运行在以下环境
系统 alpine_3.5 binutils * Up to
(excluding)
2.27-r1
22
运行在以下环境
系统 alpine_edge binutils * Up to
(excluding)
2.28-r1
23
运行在以下环境
系统 alpine_3.7 binutils * Up to
(excluding)
2.28-r1
24
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
25
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
26
运行在以下环境
系统 alpine_3.10 binutils * Up to
(excluding)
2.28-r1
27
运行在以下环境
系统 alpine_3.4 binutils * Up to
(excluding)
2.26-r1
28
运行在以下环境
系统 alpine_3.8 binutils * Up to
(excluding)
2.28-r1
29
运行在以下环境
系统 opensuse_Leap_42.2 binutils * Up to
(excluding)
2.29.1-13.1
30
运行在以下环境
系统 opensuse_Leap_42.3 binutils * Up to
(excluding)
2.29.1-13.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况