低危 Eclipse Jetty整数溢出漏洞

CVE编号

CVE-2017-7657

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-27
漏洞描述
Eclipse Jetty是Eclipse基金会的一个开源的、基于Java的Web服务器和Java Servlet容器。

Eclipse Jetty 9.2.x及之前版本、9.3.x版本和9.4.x版本中块长度的解析存在整数溢出漏洞,该漏洞源于程序未能正确的处理传输编码块。攻击者可利用该漏洞绕过授权。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=535668
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 eclipse jetty * Up to
(including)
9.2.26
运行在以下环境
应用 eclipse jetty * From
(including)
9.3.0
Up to
(excluding)
9.3.24
运行在以下环境
应用 eclipse jetty * From
(including)
9.4.0
Up to
(excluding)
9.4.11
运行在以下环境
应用 netapp e-series_santricity_management - -
运行在以下环境
应用 netapp e-series_santricity_os_controller * From
(including)
11.0
Up to
(including)
11.50.1
运行在以下环境
应用 netapp e-series_santricity_web_services - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
应用 netapp element_software_management_node - -
运行在以下环境
应用 netapp hci_storage_nodes - -
运行在以下环境
应用 netapp oncommand_system_manager 3.x -
运行在以下环境
应用 netapp oncommand_unified_manager * Up to
(excluding)
5.2.4
运行在以下环境
应用 netapp santricity_cloud_connector - -
运行在以下环境
应用 netapp snapcenter * Up to
(excluding)
4.1p3
运行在以下环境
应用 netapp snapmanager * Up to
(excluding)
3.4.2
运行在以下环境
应用 netapp snap_creator_framework * Up to
(excluding)
4.3.3
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_9 jetty9 * Up to
(excluding)
9.2.21-1+deb9u1
运行在以下环境
系统 fedora_27 jetty9 * Up to
(excluding)
9.4.11-2.v20180605.fc27
运行在以下环境
系统 fedora_28 jetty9 * Up to
(excluding)
9.4.11-2.v20180605.fc28
运行在以下环境
系统 ubuntu_18.10 jetty9 * Up to
(excluding)
9.2.26-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况