低危 mod_http2 2.4.24/2.4.25 HTTP2 Request NULL Pointer Dereference 拒绝服务漏洞

CVE编号

CVE-2017-7659

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-07-27 10:29:00
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)软件基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server 2.4.26之前的版本中存在拒绝服务漏洞。攻击者可利用该漏洞造成拒绝服务(服务器进程崩溃)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://www.debian.org/security/2017/dsa-3896
http://www.securityfocus.com/bid/99132
http://www.securitytracker.com/id/1038711
https://access.redhat.com/errata/RHSA-2017:2483
https://lists.apache.org/thread.html/1d0b746bbaa3a64890fcdab59ee9050aaa633b71...
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r15f9aa4427581a1aecb4063f1b4b983511ae1c9...
https://lists.apache.org/thread.html/r476d175be0aaf4a17680ef98c5153b4d336eaef...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfcf929bd33a6833e3f0c35eebdad70d5060665f...
https://security.gentoo.org/glsa/201710-32
https://security.netapp.com/advisory/ntap-20180601-0002/
https://support.apple.com/HT208221
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.24 -
运行在以下环境
应用 apache http_server 2.4.25 -
2
运行在以下环境
系统 alpine_3.9 apache2 * Up to
(excluding)
2.4.26-r0
3
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.26-r0
4
运行在以下环境
系统 alpine_3.6 apache2 * Up to
(excluding)
2.4.26-r0
5
运行在以下环境
系统 alpine_3.11 apache2 * Up to
(excluding)
2.4.26-r0
6
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u1
7
运行在以下环境
系统 alpine_3.7 apache2 * Up to
(excluding)
2.4.26-r0
8
运行在以下环境
系统 alpine_3.3 apache2 * Up to
(excluding)
2.4.26-r0
9
运行在以下环境
系统 alpine_3.4 apache2 * Up to
(excluding)
2.4.26-r0
10
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.26-r0
11
运行在以下环境
系统 alpine_3.8 apache2 * Up to
(excluding)
2.4.26-r0
12
运行在以下环境
系统 alpine_3.5 apache2 * Up to
(excluding)
2.4.26-r0
13
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.4.27-3.71.amzn1
14
运行在以下环境
系统 alpine_3.10 apache2 * Up to
(excluding)
2.4.26-r0
15
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.26-r0
16
运行在以下环境
系统 suse_12_SP2 apache2 * Up to
(excluding)
2.4.23-29.13.1
17
运行在以下环境
系统 suse_12_SP3 apache2 * Up to
(excluding)
2.4.23-29.13.1
18
运行在以下环境
系统 opensuse_Leap_42.3 apache2 * Up to
(excluding)
2.4.23-19.1
19
运行在以下环境
系统 fedora_25 apache2 * Up to
(excluding)
2.4.27-1.fc25
20
运行在以下环境
系统 fedora_26 apache2 * Up to
(excluding)
2.4.26-1.fc26
21
运行在以下环境
系统 fedora_24 apache2 * Up to
(excluding)
2.4.26-1.fc24
22
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.26-r0
23
运行在以下环境
系统 suse_12_SP2 apache2 * Up to
(excluding)
2.4.23-29.13.1
24
运行在以下环境
系统 suse_12_SP3 apache2 * Up to
(excluding)
2.4.23-29.13.1
25
运行在以下环境
系统 opensuse_Leap_42.3 apache2 * Up to
(excluding)
2.4.23-19.1
26
运行在以下环境
系统 suse_12_SP2 apache2 * Up to
(excluding)
2.4.23-29.13.1
27
运行在以下环境
系统 suse_12_SP3 apache2 * Up to
(excluding)
2.4.23-29.13.1
28
运行在以下环境
系统 opensuse_Leap_42.3 apache2 * Up to
(excluding)
2.4.23-19.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况