低危 Modsquitto schema-based ACL 绕过漏洞

CVE编号

CVE-2017-7668

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-06-20
漏洞描述
Apache httpd 2.2.32和2.4.24中添加的 HTTP strict parsing changes 在 token list parsing中引入了一个错误,允许AP_find_Token()搜索其输入字符串的末尾。通过恶意地伪造一系列请求头,攻击者可能会导致分段错误,或者强制AP_find_Token()返回一个不正确的值。 

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://www.debian.org/security/2017/dsa-3896
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
http://www.securityfocus.com/bid/99137
http://www.securitytracker.com/id/1038711
https://access.redhat.com/errata/RHSA-2017:2479
https://access.redhat.com/errata/RHSA-2017:2483
https://access.redhat.com/errata/RHSA-2017:3193
https://access.redhat.com/errata/RHSA-2017:3194
https://lists.apache.org/thread.html/55a068b6a5eec0b3198ae7d96a7cb412352d0ffa...
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/8d63cb8e9100f28a99429b4328e4e7cebce861d5...
https://lists.apache.org/thread.html/f7f95ac1cd9895db2714fa3ebaa0b94d0c6df360...
https://lists.apache.org/thread.html/r15f9aa4427581a1aecb4063f1b4b983511ae1c9...
https://lists.apache.org/thread.html/r476d175be0aaf4a17680ef98c5153b4d336eaef...
https://lists.apache.org/thread.html/r57608dc51b79102f3952ae06f54d5277b649c86...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r75cbe9ea3e2114e4271bbeca7aff96117b50c1b...
https://lists.apache.org/thread.html/r9ea3538f229874c80a10af473856a81fbf5f694...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rad01d817195e6cc871cb1d73b207ca326379a20...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rdca61ae990660bacb682295f2a09d34612b7bb5...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfbaf647d52c1cb843e726a0933f156366a806ce...
https://lists.apache.org/thread.html/rfcf929bd33a6833e3f0c35eebdad70d5060665f...
https://security.gentoo.org/glsa/201710-32
https://security.netapp.com/advisory/ntap-20180601-0002/
https://support.apple.com/HT208221
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.2.0 -
运行在以下环境
应用 apache http_server 2.2.11 -
运行在以下环境
应用 apache http_server 2.2.12 -
运行在以下环境
应用 apache http_server 2.2.13 -
运行在以下环境
应用 apache http_server 2.2.14 -
运行在以下环境
应用 apache http_server 2.2.15 -
运行在以下环境
应用 apache http_server 2.2.16 -
运行在以下环境
应用 apache http_server 2.2.17 -
运行在以下环境
应用 apache http_server 2.2.18 -
运行在以下环境
应用 apache http_server 2.2.19 -
运行在以下环境
应用 apache http_server 2.2.2 -
运行在以下环境
应用 apache http_server 2.2.20 -
运行在以下环境
应用 apache http_server 2.2.21 -
运行在以下环境
应用 apache http_server 2.2.22 -
运行在以下环境
应用 apache http_server 2.2.23 -
运行在以下环境
应用 apache http_server 2.2.24 -
运行在以下环境
应用 apache http_server 2.2.25 -
运行在以下环境
应用 apache http_server 2.2.26 -
运行在以下环境
应用 apache http_server 2.2.27 -
运行在以下环境
应用 apache http_server 2.2.29 -
运行在以下环境
应用 apache http_server 2.2.3 -
运行在以下环境
应用 apache http_server 2.2.30 -
运行在以下环境
应用 apache http_server 2.2.31 -
运行在以下环境
应用 apache http_server 2.2.32 -
运行在以下环境
应用 apache http_server 2.4.1 -
运行在以下环境
应用 apache http_server 2.4.10 -
运行在以下环境
应用 apache http_server 2.4.12 -
运行在以下环境
应用 apache http_server 2.4.16 -
运行在以下环境
应用 apache http_server 2.4.17 -
运行在以下环境
应用 apache http_server 2.4.18 -
运行在以下环境
应用 apache http_server 2.4.2 -
运行在以下环境
应用 apache http_server 2.4.20 -
运行在以下环境
应用 apache http_server 2.4.23 -
运行在以下环境
应用 apache http_server 2.4.25 -
运行在以下环境
系统 alpine_3.10 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.11 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.15 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.3 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.4 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.5 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.6 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.7 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.8 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_3.9 apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.26-r0
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.4.27-3.71.amzn1
运行在以下环境
系统 debian_7 apache2 * Up to
(excluding)
2.2.22-13+deb7u9
运行在以下环境
系统 debian_8 apache2 * Up to
(excluding)
2.4.10-10+deb8u5
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u1
运行在以下环境
系统 fedora_24 apache2 * Up to
(excluding)
2.4.26-1.fc24
运行在以下环境
系统 fedora_25 apache2 * Up to
(excluding)
2.4.27-1.fc25
运行在以下环境
系统 fedora_26 apache2 * Up to
(excluding)
2.4.26-1.fc26
运行在以下环境
系统 oracle_6 apache2 * Up to
(excluding)
2.2.15-60.0.1.el6_9.4
运行在以下环境
系统 oracle_7 apache2 * Up to
(excluding)
2.4.6-67.0.1.el7_4.2
运行在以下环境
系统 suse_11_SP4 apache2 * Up to
(excluding)
2.2.34-70.12.1
运行在以下环境
系统 ubuntu_14.04 apache2 * Up to
(excluding)
2.4.7-1ubuntu4.16
运行在以下环境
系统 ubuntu_16.04 apache2 * Up to
(excluding)
2.4.18-2ubuntu3.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况