低危 LibreOffice 'SVMConverter::ImplConvertFromSVM1'函数堆缓冲区溢出漏洞

CVE编号

CVE-2017-7856

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-04-14
漏洞描述
LibreOffice是文档基金会(The Document Foundation,TDF)开发的一套免费开源的办公软件套件。该套件由Writer(文本文档)、Calc(电子表格)和Impress(演示文稿)等应用程序组成。

LibreOffice 2017-03-11之前的版本中的vcl/source/gdi/svmconverter.cxx文件的'SVMConverter::ImplConvertFromSVM1'函数'存在堆缓冲区溢出漏洞。攻击者可利用该漏洞造成拒绝服务(越边界写入)。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/LibreOffice/core/commit/28e61b634353110445e334ccaa415d7fb6629d62
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * Up to
(including)
5.2.6.1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 fedora_24 libreoffice-draw * Up to
(excluding)
5.1.6.2-8.fc24
运行在以下环境
系统 fedora_24 libreoffice-langpack- * Up to
(excluding)
5.1.6.2-8.fc24
运行在以下环境
系统 fedora_24 libreoffice-langpack-eu * Up to
(excluding)
5.1.6.2-8.fc24
运行在以下环境
系统 fedora_24 libreoffice-langpack-sk * Up to
(excluding)
5.1.6.2-8.fc24
运行在以下环境
系统 fedora_24 libreoffice-langpack-ta * Up to
(excluding)
5.1.6.2-8.fc24
运行在以下环境
系统 fedora_24 libreoffice-pyuno * Up to
(excluding)
5.1.6.2-8.fc24
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况