低危 GD Graphics Library至 5.6.30 gd_gif_in.c gdImageCreateFromGifCtx GIF Image 信息泄漏漏洞

CVE编号

CVE-2017-7890

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-03
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。

PHP 'gd_gif_in.c'存在内存破坏漏洞。攻击者可利用该漏洞实现拒绝服务或导致敏感信息泄露。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://bugs.php.net/bug.php?id=74435
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.6.30
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.10 -
运行在以下环境
应用 php php 7.0.11 -
运行在以下环境
应用 php php 7.0.12 -
运行在以下环境
应用 php php 7.0.13 -
运行在以下环境
应用 php php 7.0.14 -
运行在以下环境
应用 php php 7.0.15 -
运行在以下环境
应用 php php 7.0.16 -
运行在以下环境
应用 php php 7.0.17 -
运行在以下环境
应用 php php 7.0.18 -
运行在以下环境
应用 php php 7.0.19 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.20 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
应用 php php 7.0.5 -
运行在以下环境
应用 php php 7.0.6 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
应用 php php 7.0.8 -
运行在以下环境
应用 php php 7.0.9 -
运行在以下环境
应用 php php 7.1.0 -
运行在以下环境
应用 php php 7.1.1 -
运行在以下环境
应用 php php 7.1.2 -
运行在以下环境
应用 php php 7.1.3 -
运行在以下环境
应用 php php 7.1.4 -
运行在以下环境
应用 php php 7.1.5 -
运行在以下环境
应用 php php 7.1.6 -
运行在以下环境
系统 alpine_3.4 gd * Up to
(excluding)
2.2.5-r0
运行在以下环境
系统 alpine_3.5 gd * Up to
(excluding)
2.2.5-r0
运行在以下环境
系统 alpine_3.6 gd * Up to
(excluding)
2.2.5-r0
运行在以下环境
系统 alpine_3.7 gd * Up to
(excluding)
7.1.7-r0
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
7.0.21-1.23.amzn1
运行在以下环境
系统 centos_7 gd * Up to
(excluding)
5.4.16-43.el7_4.1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u9
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 debian_9 gd * Up to
(excluding)
2.2.4-2+deb9u1
运行在以下环境
系统 fedora_25 gd * Up to
(excluding)
2.2.5-1.fc25
运行在以下环境
系统 fedora_26 gd * Up to
(excluding)
2.2.5-1.fc26
运行在以下环境
系统 fedora_27 gd * Up to
(excluding)
2.2.5-1.fc27
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
7.0.7-19.1
运行在以下环境
系统 opensuse_Leap_42.3 gd * Up to
(excluding)
5.5.14-82.1
运行在以下环境
系统 oracle_7 gd * Up to
(excluding)
5.4.16-43.el7_4.1
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-43.el7_4.1
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
5.3.17-112.5.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-24.17
运行在以下环境
系统 suse_12_SP4 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 suse_12_SP5 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.7
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.7
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.7
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.7
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况