低危 Haxx curl和libcurl越界读取拒绝服务漏洞

CVE编号

CVE-2017-8818

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-11-30
漏洞描述
Haxx curl和libcurl都是瑞典Haxx公司的产品。curl是一套利用URL语法在命令行下工作的文件传输工具。libcurl是一个免费、开源的客户端URL传输库。

Haxx curl和libcurl 7.57.0之前的版本(32位平台)存在越界读取拒绝服务漏洞,该漏洞源于分配的内存较小。攻击者可利用该漏洞造成拒绝服务(越边界访问和应用程序崩溃)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://curl.haxx.se/docs/adv_2017-af0a.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl 7.56.0 -
运行在以下环境
应用 haxx curl 7.56.1 -
运行在以下环境
应用 haxx libcurl 7.56.0 -
运行在以下环境
应用 haxx libcurl 7.56.1 -
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.16 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.57.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.61.1-9.amzn2.0.1
运行在以下环境
系统 suse_12 curl * Up to
(excluding)
7.60.0-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况