低危 在正则表达式编译期间,堆缓冲区在next_state_val()中溢出

CVE编号

CVE-2017-9226

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2017-05-25
漏洞描述
在Oniguruma 6.2.0中发现了一个问题,在Ruby中通过2.4.1使用Oniguruma-mod,在PHP中通过7.1.5使用mbstring。在正则表达式编译期间,在next_state_val()中发生堆越界写入或读取。在fetch_token()和fetch_token_in_cc()中无法正确处理大于0xff的八进制数。包含“\ 700”形式的八进制数的格式错误的正则表达式将在next_state_val()中生成大于0xff的无效代码点值,从而导致越界写入内存损坏。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 oniguruma_project oniguruma 6.2.0 -
运行在以下环境
应用 php php * Up to
(including)
7.1.5
运行在以下环境
应用 ruby-lang ruby * Up to
(including)
2.4.1
运行在以下环境
系统 alpine_3.4 php5 * Up to
(excluding)
5.6.31-r0
运行在以下环境
系统 alpine_3.5 php5 * Up to
(excluding)
5.6.31-r0
运行在以下环境
系统 alpine_3.6 php5 * Up to
(excluding)
7.1.9-r0
运行在以下环境
系统 alpine_3.7 php5 * Up to
(excluding)
5.6.31-r0
运行在以下环境
系统 alpine_3.8 php5 * Up to
(excluding)
5.6.31-r0
运行在以下环境
系统 amazon_2 oniguruma * Up to
(excluding)
5.9.6-1.amzn2.0.7
运行在以下环境
系统 amazon_AMI php56 * Up to
(excluding)
7.0.21-1.23.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
6.1.3-2
运行在以下环境
系统 debian_10 libonig * Up to
(excluding)
6.1.3-2
运行在以下环境
系统 debian_11 libonig * Up to
(excluding)
6.1.3-2
运行在以下环境
系统 debian_12 libonig * Up to
(excluding)
6.1.3-2
运行在以下环境
系统 debian_7 libonig * Up to
(excluding)
5.9.1-1+deb7u1
运行在以下环境
系统 debian_8 libonig * Up to
(excluding)
5.9.5-3.2+deb8u1
运行在以下环境
系统 fedora_24 oniguruma * Up to
(excluding)
5.6.31-1.fc24
运行在以下环境
系统 fedora_25 oniguruma * Up to
(excluding)
7.0.21-1.fc25
运行在以下环境
系统 fedora_26 oniguruma * Up to
(excluding)
7.1.7-1.fc26
运行在以下环境
系统 fedora_EPEL_7 jq * Up to
(excluding)
1.6-2.el7
运行在以下环境
系统 opensuse_Leap_42.2 php7-bz2 * Up to
(excluding)
5.5.14-77.6.1
运行在以下环境
系统 suse_11_SP4 php53-odbc * Up to
(excluding)
5.3.17-108.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-108
运行在以下环境
系统 ubuntu_14.04 php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.22
运行在以下环境
系统 ubuntu_14.04.6_lts libonig * Up to
(excluding)
5.9.1-1ubuntu1.1
运行在以下环境
系统 ubuntu_16.04 php7.0 * Up to
(excluding)
5.9.6-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts libonig * Up to
(excluding)
5.9.6-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04 libonig * Up to
(excluding)
6.3.0-1
运行在以下环境
系统 ubuntu_18.04.5_lts libonig * Up to
(excluding)
6.3.0-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况