低危 libexpat up to 2.2.0 Loop 拒绝服务漏洞

CVE编号

CVE-2017-9233

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-07-26
漏洞描述
libexpat 2.2.0及更早版本(Expat XML Parser Library)中的XML外部实体漏洞允许攻击者使用来自外部DTD的格式错误的 external entity definition将parse置于无限循环中。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://libexpat.github.io/doc/cve-2017-9233/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat_project libexpat * Up to
(including)
2.2.0
运行在以下环境
系统 alpine_3.10 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.11 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.12 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.13 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.14 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.15 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.16 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.4 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.5 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.6 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.7 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.8 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_3.9 expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 alpine_edge expat * Up to
(excluding)
2.2.0-r1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.2.0-2+deb9u1
运行在以下环境
系统 debian_7 expat * Up to
(excluding)
2.1.0-1+deb7u5
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
2.1.0-6+deb8u6
运行在以下环境
系统 debian_9 expat * Up to
(excluding)
2.2.0-2+deb9u1
运行在以下环境
系统 fedora_24 expat * Up to
(excluding)
2.2.1-1.fc24
运行在以下环境
系统 fedora_25 expat * Up to
(excluding)
2.2.1-1.fc25
运行在以下环境
系统 fedora_26 expat * Up to
(excluding)
2.2.1-1.fc26
运行在以下环境
系统 opensuse_Leap_42.2 expat * Up to
(excluding)
2.1.0-24.1
运行在以下环境
系统 opensuse_Leap_42.3 expat * Up to
(excluding)
2.1.0-24.1
运行在以下环境
系统 suse_11_SP4 expat * Up to
(excluding)
2.0.1-88.42.3.2
运行在以下环境
系统 suse_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 suse_12_SP2 expat * Up to
(excluding)
2.1.0-21.3.1
运行在以下环境
系统 suse_12_SP3 expat * Up to
(excluding)
2.1.0-21.3.1
运行在以下环境
系统 suse_12_SP4 expat * Up to
(excluding)
3.4.10-25.39.3
运行在以下环境
系统 suse_12_SP5 expat * Up to
(excluding)
3.4.10-25.39.2
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.4
运行在以下环境
系统 ubuntu_14.04.6_lts expat * Up to
(excluding)
2.1.0-4ubuntu1.4
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_18.04.5_lts expat * Up to
(excluding)
2.2.1-2
运行在以下环境
系统 ubuntu_18.10 expat * Up to
(excluding)
2.2.1-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-611 XML外部实体引用的不恰当限制(XXE)
CWE-835 不可达退出条件的循环(无限循环)
阿里云安全产品覆盖情况