低危 Jetty util/security/Password. java file安全绕过漏洞

CVE编号

CVE-2017-9776

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-06-23
漏洞描述
在0.56之前的Poppler中的pdftocairo中的JBIG2Stream.cc中的堆缓冲区溢出导致堆溢出溢出允许远程攻击者通过精心制作的PDF文档导致拒绝服务(应用程序崩溃)或可能具有未指定的其他影响。

解决建议

目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://github.com/danigm/poppler
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop poppler * Up to
(including)
0.55.0
运行在以下环境
系统 amazon_AMI poppler * Up to
(excluding)
0.26.5-17.17.amzn1
运行在以下环境
系统 debian_7 poppler * Up to
(excluding)
0.18.4-6+deb7u2
运行在以下环境
系统 debian_8 poppler * Up to
(excluding)
0.26.5-2+deb8u2
运行在以下环境
系统 debian_9 poppler * Up to
(excluding)
0.48.0-2+deb9u1
运行在以下环境
系统 fedora_24 poppler * Up to
(excluding)
0.41.0-3.fc24
运行在以下环境
系统 fedora_25 poppler * Up to
(excluding)
0.45.0-5.fc25
运行在以下环境
系统 fedora_26 poppler * Up to
(excluding)
0.52.0-3.fc26
运行在以下环境
系统 opensuse_Leap_42.2 poppler * Up to
(excluding)
0.43.0-5.1
运行在以下环境
系统 opensuse_Leap_42.3 poppler * Up to
(excluding)
0.43.0-5.1
运行在以下环境
系统 oracle_6 poppler * Up to
(excluding)
0.12.4-12.el6_9
运行在以下环境
系统 oracle_7 poppler * Up to
(excluding)
0.26.5-17.el7_4
运行在以下环境
系统 suse_12_SP2 poppler * Up to
(excluding)
0.24.4-14.6.1
运行在以下环境
系统 suse_12_SP3 poppler * Up to
(excluding)
0.43.0-16.5.1
运行在以下环境
系统 ubuntu_16.04 poppler * Up to
(excluding)
0.41.0-0ubuntu1.4
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况