低危 OpenSSL安全限制绕过漏洞(CNVD-2018-06538)

CVE编号

CVE-2018-0733

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-28 10:29:00
漏洞描述
OpenSSL是一种开放源码的SSL实现,用来实现网络通信的高强度加密。
OpenSSL 1.1.0-1.1.0g版本PA-RISC CRYPTO_memcmp函数实现中存在安全漏洞,攻击者通过构造的消息利用此漏洞可绕过安全限制。
解决建议
OpenSSL Project已经为此发布了一个安全公告(20180327)以及相应补丁:
https://www.openssl.org/news/secadv/20180327.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * From
(including)
1.1.0
Up to
(including)
1.1.0g
2
运行在以下环境
系统 alpine_3.5 openssl * Up to
(excluding)
1.0.2o-r0
3
运行在以下环境
系统 amazon_AMI openssl * Up to
(excluding)
1.0.2k-12.110.amzn1
4
运行在以下环境
系统 alpine_3.3 openssl * Up to
(excluding)
1.0.2o-r0
5
运行在以下环境
系统 alpine_3.6 openssl * Up to
(excluding)
1.0.2o-r0
6
运行在以下环境
系统 alpine_3.8 openssl * Up to
(excluding)
1.0.2o-r0
7
运行在以下环境
系统 debian_9 openssl * Up to
(excluding)
1.1.0f-3+deb9u2
8
运行在以下环境
系统 alpine_3.4 openssl * Up to
(excluding)
1.0.2o-r0
9
运行在以下环境
系统 alpine_3.7 openssl * Up to
(excluding)
1.0.2o-r0
10
运行在以下环境
系统 fedora_26 openssl * Up to
(excluding)
1.1.0h-1.fc26
11
运行在以下环境
系统 fedora_28 openssl * Up to
(excluding)
1.1.0h-2.fc28
12
运行在以下环境
系统 fedora_27 openssl * Up to
(excluding)
1.1.0h-1.fc27
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况