低危 OpenSSL 旁道攻击信息泄露漏洞

CVE编号

CVE-2018-0734

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-31
漏洞描述
OpenSSL DSA签名算法已被证明易受定时侧信道攻击。攻击者可以使用签名算法中的变体来恢复私钥。已在OpenSSL 1.1.1a(受影响的1.1.1)中修复。已在OpenSSL 1.1.0j(受影响的1.1.0-1.1.0i)中修复。已在OpenSSL 1.0.2q(受影响的1.0.2-1.0.2p)中修复。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
参考链接
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00030.html
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00056.html
http://www.securityfocus.com/bid/105758
https://access.redhat.com/errata/RHSA-2019:2304
https://access.redhat.com/errata/RHSA-2019:3700
https://access.redhat.com/errata/RHSA-2019:3932
https://access.redhat.com/errata/RHSA-2019:3933
https://access.redhat.com/errata/RHSA-2019:3935
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=43e6a58d4991a451...
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=8abfe72e8c1de1b9...
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=ef11e19d1365eea2...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
https://security.netapp.com/advisory/ntap-20181105-0002/
https://security.netapp.com/advisory/ntap-20190118-0002/
https://security.netapp.com/advisory/ntap-20190423-0002/
https://usn.ubuntu.com/3840-1/
https://www.debian.org/security/2018/dsa-4348
https://www.debian.org/security/2018/dsa-4355
https://www.openssl.org/news/secadv/20181030.txt
https://www.oracle.com/security-alerts/cpuapr2020.html
https://www.oracle.com/security-alerts/cpujan2020.html
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
https://www.tenable.com/security/tns-2018-16
https://www.tenable.com/security/tns-2018-17
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp cloud_backup - -
运行在以下环境
应用 netapp oncommand_unified_manager * -
运行在以下环境
应用 netapp santricity_smi-s_provider - -
运行在以下环境
应用 netapp snapcenter - -
运行在以下环境
应用 netapp steelstore - -
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 nodejs node.js * From
(including)
10.13.0
Up to
(including)
10.14.1
运行在以下环境
应用 nodejs node.js * From
(including)
11.0.0
Up to
(including)
11.4.0
运行在以下环境
应用 nodejs node.js * From
(including)
6.9.0
Up to
(including)
6.15.1
运行在以下环境
应用 nodejs node.js * From
(including)
8.9.0
Up to
(including)
8.14.0
运行在以下环境
应用 openssl openssl * From
(including)
1.0.2
Up to
(including)
1.0.2p
运行在以下环境
应用 openssl openssl * From
(including)
1.1.0
Up to
(including)
1.1.0i
运行在以下环境
应用 openssl openssl 1.1.1 -
运行在以下环境
应用 oracle api_gateway 11.1.2.4.0 -
运行在以下环境
应用 oracle e-business_suite_technology_stack 0.9.8 -
运行在以下环境
应用 oracle e-business_suite_technology_stack 1.0.0 -
运行在以下环境
应用 oracle e-business_suite_technology_stack 1.0.1 -
运行在以下环境
应用 oracle enterprise_manager_base_platform 12.1.0.5.0 -
运行在以下环境
应用 oracle enterprise_manager_base_platform 13.2.0.0.0 -
运行在以下环境
应用 oracle enterprise_manager_base_platform 13.3.0.0.0 -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.3.3 -
运行在以下环境
应用 oracle mysql_enterprise_backup * From
(including)
3.0
Up to
(including)
3.12.3
运行在以下环境
应用 oracle mysql_enterprise_backup * From
(including)
4.0
Up to
(including)
4.1.2
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.55 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.56 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.57 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management * From
(including)
17.7
Up to
(including)
17.12
运行在以下环境
应用 oracle primavera_p6_professional_project_management 15.1 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management 15.2 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management 16.1 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management 16.2 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management 18.8 -
运行在以下环境
应用 oracle primavera_p6_professional_project_management 8.4 -
运行在以下环境
应用 oracle tuxedo 12.1.1.0.0 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 openssl * Up to
(excluding)
1.0.2k-19.2.al7
运行在以下环境
系统 alpine_3.10 openssl * Up to
(excluding)
11.3.0-r0
运行在以下环境
系统 alpine_3.11 openssl * Up to
(excluding)
11.3.0-r0
运行在以下环境
系统 alpine_3.12 openssl * Up to
(excluding)
11.3.0-r0
运行在以下环境
系统 alpine_3.13 openssl * Up to
(excluding)
10.14.0-r0
运行在以下环境
系统 alpine_3.14 openssl * Up to
(excluding)
1.1.1a-r0
运行在以下环境
系统 alpine_3.15 openssl * Up to
(excluding)
10.14.0-r0
运行在以下环境
系统 alpine_3.3 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.4 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.5 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.6 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.7 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.8 openssl * Up to
(excluding)
1.0.2q-r0
运行在以下环境
系统 alpine_3.9 openssl * Up to
(excluding)
11.3.0-r0
运行在以下环境
系统 alpine_edge openssl * Up to
(excluding)
1.1.1a-r0
运行在以下环境
系统 amazon linux_2 openssl * Up to
(excluding)
1.0.2k-19.amzn2.0.1
运行在以下环境
系统 amazon linux_AMI openssl * Up to
(excluding)
1.0.2k-16.148.amzn1
运行在以下环境
系统 amazon_2 openssl * Up to
(excluding)
1.0.2k-19.amzn2.0.1
运行在以下环境
系统 amazon_AMI openssl * Up to
(excluding)
1.0.2k-16.148.amzn1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.10 -
运行在以下环境
系统 centos_8 openssl * Up to
(excluding)
1.1.1c-2.el8
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_9 openssl * Up to
(excluding)
1.1.0j-1~deb9u1
运行在以下环境
系统 fedora_29 openssl * Up to
(excluding)
1.0.2o-7.fc29
运行在以下环境
系统 fedora_30 openssl * Up to
(excluding)
1.0.2o-7.fc30
运行在以下环境
系统 fedora_31 openssl * Up to
(excluding)
1.0.2o-8.fc31
运行在以下环境
系统 netapp cn1610_firmware - -
运行在以下环境
系统 opensuse_Leap_15.0 openssl * Up to
(excluding)
1.1.0i-lp150.3.15.1
运行在以下环境
系统 opensuse_Leap_15.1 openssl * Up to
(excluding)
6.0.10-lp151.2.6.1
运行在以下环境
系统 opensuse_Leap_42.3 openssl * Up to
(excluding)
6.16.0-18.1
运行在以下环境
系统 oracle linux_7 openssl * Up to
(excluding)
1.0.2k-19.0.1.el7
运行在以下环境
系统 oracle linux_8 openssl * Up to
(excluding)
1.1.1c-2.el8
运行在以下环境
系统 oracle_7 openssl * Up to
(excluding)
1.0.2k-19.0.1.el7
运行在以下环境
系统 oracle_8 openssl * Up to
(excluding)
1.1.1c-2.el8
运行在以下环境
系统 redhat_7 openssl * Up to
(excluding)
1:1.0.2k-19.el7
运行在以下环境
系统 redhat_8 openssl * Up to
(excluding)
1.1.1c-2.el8
运行在以下环境
系统 sles_11_SP4 openssl * Up to
(excluding)
0.9.8j-0.106.18.1
运行在以下环境
系统 sles_12 libopenssl-devel * Up to
(excluding)
1.0.2j-60.46
运行在以下环境
系统 sles_12_SP3 openssl * Up to
(excluding)
0.9.8j-106.9.1
运行在以下环境
系统 sles_12_SP4 openssl * Up to
(excluding)
1.1.1-2.3.1
运行在以下环境
系统 suse_11_SP4 openssl * Up to
(excluding)
0.9.8j-0.106.18.1
运行在以下环境
系统 suse_12_SP3 openssl * Up to
(excluding)
0.9.8j-106.9.1
运行在以下环境
系统 suse_12_SP4 openssl * Up to
(excluding)
1.1.1-2.3.1
运行在以下环境
系统 ubuntu_14.04 openssl * Up to
(excluding)
1.0.1f-1ubuntu2.27
运行在以下环境
系统 ubuntu_14.04_lts openssl * Up to
(excluding)
1.0.1f-1ubuntu2.27
运行在以下环境
系统 ubuntu_16.04 openssl * Up to
(excluding)
1.0.2g-1ubuntu4.14
运行在以下环境
系统 ubuntu_16.04_lts openssl * Up to
(excluding)
1.0.2g-1ubuntu4.14
运行在以下环境
系统 ubuntu_18.04 openssl * Up to
(excluding)
1.1.0g-2ubuntu4.3
运行在以下环境
系统 ubuntu_18.04_lts openssl * Up to
(excluding)
1.1.0g-2ubuntu4.3
运行在以下环境
系统 ubuntu_18.10 openssl * Up to
(excluding)
1.1.1-1ubuntu2.1
运行在以下环境
系统 ubuntu_20.04 openssl * Up to
(excluding)
1.1.1a-1ubuntu2
运行在以下环境
系统 ubuntu_21.04 openssl * Up to
(excluding)
1.1.1a-1ubuntu2
运行在以下环境
硬件 netapp cn1610 - -
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-327 使用已被攻破或存在风险的密码学算法
阿里云安全产品覆盖情况