低危 OpenSSL RSA密钥生成算法缓存旁信道攻击漏洞

CVE编号

CVE-2018-0737

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-17 07:29:00
漏洞描述
发现OpenSSL RSA密钥生成容易受到缓存侧通道攻击。在RSA密钥生成过程中,具有足够的权限来发起高速缓存定时攻击的攻击者可以恢复部分私钥。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=6939eab03a6e23d2bd2c3f5e34fe1d48e542e787
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=349a41da1ad88ad87825414752a8ff5fdd6a6c3f
参考链接
http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
http://www.securityfocus.com/bid/103766
http://www.securitytracker.com/id/1040685
https://access.redhat.com/errata/RHSA-2018:3221
https://access.redhat.com/errata/RHSA-2018:3505
https://access.redhat.com/errata/RHSA-2019:3932
https://access.redhat.com/errata/RHSA-2019:3933
https://access.redhat.com/errata/RHSA-2019:3935
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=349a41da1ad88ad8...
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=6939eab03a6e23d2...
https://lists.debian.org/debian-lts-announce/2018/07/msg00043.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://nodejs.org/en/blog/vulnerability/august-2018-security-releases/
https://security.gentoo.org/glsa/201811-21
https://security.netapp.com/advisory/ntap-20180726-0003/
https://securityadvisories.paloaltonetworks.com/Home/Detail/133
https://usn.ubuntu.com/3628-1/
https://usn.ubuntu.com/3628-2/
https://usn.ubuntu.com/3692-1/
https://usn.ubuntu.com/3692-2/
https://www.debian.org/security/2018/dsa-4348
https://www.debian.org/security/2018/dsa-4355
https://www.openssl.org/news/secadv/20180416.txt
https://www.oracle.com//security-alerts/cpujul2021.html
https://www.oracle.com/security-alerts/cpuapr2020.html
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
https://www.tenable.com/security/tns-2018-12
https://www.tenable.com/security/tns-2018-13
https://www.tenable.com/security/tns-2018-14
https://www.tenable.com/security/tns-2018-17
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * From
(including)
1.0.2b
Up to
(including)
1.0.2o
运行在以下环境
应用 openssl openssl * From
(including)
1.1.0
Up to
(including)
1.1.0h
2
运行在以下环境
系统 amazon_AMI openssl * Up to
(excluding)
1.0.2k-8.107.amzn1
3
运行在以下环境
系统 alpine_3.3 openssl * Up to
(excluding)
1.0.2o-r1
4
运行在以下环境
系统 amazon_2 openssl * Up to
(excluding)
1.0.2k-12.amzn2.0.1
5
运行在以下环境
系统 alpine_3.4 openssl * Up to
(excluding)
1.0.2o-r2
6
运行在以下环境
系统 alpine_3.6 openssl * Up to
(excluding)
1.0.2o-r1
7
运行在以下环境
系统 alpine_3.5 openssl * Up to
(excluding)
1.0.2o-r1
8
运行在以下环境
系统 alpine_3.8 openssl * Up to
(excluding)
1.0.2o-r2
9
运行在以下环境
系统 debian_8 openssl * Up to
(excluding)
1.0.1t-1+deb8u8
10
运行在以下环境
系统 alpine_3.7 openssl * Up to
(excluding)
1.0.2o-r1
11
运行在以下环境
系统 debian_9 openssl * Up to
(excluding)
1.1.0f-3+deb9u2
12
运行在以下环境
系统 oracle_6 openssl * Up to
(excluding)
1.0.1e-58.0.1.el6_10
13
运行在以下环境
系统 suse_12_SP3 openssl * Up to
(excluding)
0.9.8j-106.6.1
14
运行在以下环境
系统 opensuse_Leap_42.3 openssl * Up to
(excluding)
0.9.8j-24.1
15
运行在以下环境
系统 oracle_7 openssl * Up to
(excluding)
1.0.2k-12.0.3.el7
16
运行在以下环境
系统 fedora_30 openssl * Up to
(excluding)
1.0.2o-7.fc30
17
运行在以下环境
系统 fedora_29 openssl * Up to
(excluding)
1.0.2o-7.fc29
18
运行在以下环境
系统 fedora_31 openssl * Up to
(excluding)
1.0.2o-8.fc31
19
运行在以下环境
系统 fedora_28 openssl * Up to
(excluding)
1.1.0i-1.fc28
20
运行在以下环境
系统 fedora_27 openssl * Up to
(excluding)
1.1.0i-1.fc27
21
运行在以下环境
系统 suse_11_SP4 openssl * Up to
(excluding)
0.9.8j-0.106.15.1
22
运行在以下环境
系统 opensuse_Leap_15.0 openssl * Up to
(excluding)
1.1.0i-lp150.3.18.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-327 使用已被攻破或存在风险的密码学算法
阿里云安全产品覆盖情况