低危 libcurl越界访问拒绝服务信息泄露

CVE编号

CVE-2018-1000005

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-01-25
漏洞描述
libcurl 7.49.0到7.57.0,包含7.57.0,在处理HTTP/2 trailers的代码读取时,存在越界。据报道(https://github.com/curl/curl/pull/2231),读取 HTTP/2 trailer 可能会破坏未来的trailers,因为存储的大小比所需的小一个字节。问题是,从HTTP / 2trailers数据创建类似HTTP / 1的header文件的代码曾经将一个字符串(如`:`)附加到目标缓冲区,而最近这个更改为`:`(后面添加了一个空格)冒号)但后续math并未相应更新。访问时,数据被读出边界并导致崩溃或(太大)数据传递给客户端写入。如果有人提供回送或使用 trailers的服务,这可能导致拒绝服务情况或信息泄露。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://curl.haxx.se/docs/adv_2018-824a.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx libcurl * From
(including)
7.49.0
Up to
(including)
7.57.0
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.58.0-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.58.0-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.58.0-r0
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.58.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.55.1-9.amzn2.0.1
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.53.1-14.81.amzn1
运行在以下环境
系统 debian_9 curl * Up to
(excluding)
7.52.1-5+deb9u4
运行在以下环境
系统 fedora_26 curl * Up to
(excluding)
7.53.1-14.fc26
运行在以下环境
系统 fedora_27 curl * Up to
(excluding)
7.55.1-9.fc27
运行在以下环境
系统 suse_12 curl * Up to
(excluding)
7.60.0-2
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.6
运行在以下环境
系统 ubuntu_16.04.7_lts curl * Up to
(excluding)
7.47.0-1ubuntu2.6
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况