低危 Memcached 1.5.5 UDP Support Message Flooding 拒绝服务漏洞

CVE编号

CVE-2018-1000115

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-06
漏洞描述
Memcached是美国软件开发者布莱德-菲兹派翠克(Brad Fitzpatrick)所研发的一套高性能的分布式内存对象缓存系统。该系统通过在内存中缓存数据和对象来减少读取数据库的次数,从而提高网站访问速度。

Memcached 1.5.5版本中存在安全漏洞,该漏洞源于程序未能充分的限制Network Message Volume。攻击者可利用该漏洞造成拒绝服务。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/memcached/memcached/wiki/ReleaseNotes156
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 memcached memcached 1.5.5 -
运行在以下环境
应用 redhat openstack 10.0 -
运行在以下环境
应用 redhat openstack 11.0 -
运行在以下环境
应用 redhat openstack 12.0 -
运行在以下环境
应用 redhat openstack 8.0 -
运行在以下环境
应用 redhat openstack 9.0 -
运行在以下环境
系统 alpine_3.4 memcached * Up to
(excluding)
1.4.33-r2
运行在以下环境
系统 alpine_3.5 memcached * Up to
(excluding)
1.4.33-r2
运行在以下环境
系统 alpine_3.6 memcached * Up to
(excluding)
1.4.36-r2
运行在以下环境
系统 amazon_2 memcached * Up to
(excluding)
1.4.15-10.amzn2.1.1
运行在以下环境
系统 amazon_AMI memcached * Up to
(excluding)
1.4.15-10.15.amzn1
运行在以下环境
系统 debian_8 memcached * Up to
(excluding)
1.4.21-1.1+deb8u1
运行在以下环境
系统 debian_9 memcached * Up to
(excluding)
1.4.33-1+deb9u1
运行在以下环境
系统 fedora_26 memcached * Up to
(excluding)
1.4.39-2.fc26
运行在以下环境
系统 fedora_27 memcached * Up to
(excluding)
1.5.7-1.fc27
运行在以下环境
系统 opensuse_Leap_42.3 memcached * Up to
(excluding)
1.4.39-11.6.1
运行在以下环境
系统 suse_12_SP3 memcached * Up to
(excluding)
1.4.39-4.6.1
运行在以下环境
系统 ubuntu_16.04 memcached * Up to
(excluding)
1.4.25-2ubuntu1.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况