低危 curl 缓冲区错误拒绝服务漏洞

CVE编号

CVE-2018-1000120

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-15
漏洞描述
在curl 7.12.3中存在缓冲区溢出,在FTP URL处理中包含curl 7.58.0,允许攻击者导致拒绝服务或其他影响。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://curl.haxx.se/docs/adv_2018-9cd6.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * From
(including)
7.12.3
Up to
(including)
7.58.0
运行在以下环境
应用 oracle communications_webrtc_session_controller * Up to
(excluding)
7.2
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.2.2 -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.3.3 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.55 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.56 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.57 -
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.59.0-r0
运行在以下环境
系统 amazon linux_2 curl * Up to
(excluding)
7.55.1-10.amzn2.0.1
运行在以下环境
系统 amazon linux_AMI curl * Up to
(excluding)
7.53.1-16.84.amzn1
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.55.1-10.amzn2.0.1
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.53.1-16.84.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 17.10 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_7 curl * Up to
(excluding)
7.26.0-1+wheezy25
运行在以下环境
系统 debian_8 curl * Up to
(excluding)
7.38.0-4+deb8u1
运行在以下环境
系统 debian_9 curl * Up to
(excluding)
7.52.1-5+deb9u5
运行在以下环境
系统 fedora_26 curl * Up to
(excluding)
7.53.1-16.fc26
运行在以下环境
系统 fedora_27 curl * Up to
(excluding)
7.55.1-10.fc27
运行在以下环境
系统 fedora_28 curl * Up to
(excluding)
7.59.0-1.fc28
运行在以下环境
系统 opensuse_Leap_42.3 curl * Up to
(excluding)
7.37.0-33.1
运行在以下环境
系统 oracle linux_7 curl * Up to
(excluding)
7.29.0-51.el7
运行在以下环境
系统 oracle_7 curl * Up to
(excluding)
7.29.0-51.el7
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 curl * Up to
(excluding)
0:7.29.0-51.el7
运行在以下环境
系统 sles_11_SP4 curl * Up to
(excluding)
7.37.0-70.27.1
运行在以下环境
系统 sles_12 curl * Up to
(excluding)
7.37.0-37.17
运行在以下环境
系统 sles_12_SP2 curl * Up to
(excluding)
7.37.0-37.17.1
运行在以下环境
系统 sles_12_SP3 curl * Up to
(excluding)
7.37.0-37.17.1
运行在以下环境
系统 suse_11_SP4 curl * Up to
(excluding)
7.37.0-70.27.1
运行在以下环境
系统 suse_12_SP2 curl * Up to
(excluding)
7.37.0-37.17.1
运行在以下环境
系统 suse_12_SP3 curl * Up to
(excluding)
7.37.0-37.17.1
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.15
运行在以下环境
系统 ubuntu_14.04_lts curl * Up to
(excluding)
7.35.0-1ubuntu2.15
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.7
运行在以下环境
系统 ubuntu_16.04_lts curl * Up to
(excluding)
7.47.0-1ubuntu2.7
运行在以下环境
系统 ubuntu_18.04 curl * Up to
(excluding)
7.58.0-2ubuntu3
运行在以下环境
系统 ubuntu_18.04_lts curl * Up to
(excluding)
7.58.0-2ubuntu3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况