低危 HTTP服务器权限绕过

CVE编号

CVE-2018-1000132

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-15
漏洞描述
Mercurial 4.5及更早版本在协议服务器中包含一个错误的访问控制(CWE-285)漏洞,可能导致未经授权的数据访问。此攻击似乎可通过网络连接进行攻击。此漏洞似乎已在4.5.1中修复。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mercurial mercurial * Up to
(excluding)
4.5.1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mercurial * Up to
(excluding)
2.6.2-10.1.al7
运行在以下环境
系统 alpine_3.5 mercurial * Up to
(excluding)
4.5.2-r0
运行在以下环境
系统 alpine_3.6 mercurial * Up to
(excluding)
4.5.2-r0
运行在以下环境
系统 alpine_3.7 mercurial * Up to
(excluding)
4.5.2-r0
运行在以下环境
系统 debian_7 mercurial * Up to
(excluding)
2.2.2-4+deb7u7
运行在以下环境
系统 debian_8 mercurial * Up to
(excluding)
3.1.2-2+deb8u4
运行在以下环境
系统 debian_9 mercurial * Up to
(excluding)
4.0-1+deb9u2
运行在以下环境
系统 opensuse_Leap_42.3 mercurial * Up to
(excluding)
4.2.3-12.1
运行在以下环境
系统 oracle_7 mercurial * Up to
(excluding)
2.6.2-10.el7
运行在以下环境
系统 redhat_7 emacs-mercurial * Up to
(excluding)
0:2.6.2-10.el7
运行在以下环境
系统 ubuntu_14.04 mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_14.04.6_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_16.04 mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_16.04.7_lts mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_18.04.5_lts mercurial * Up to
(excluding)
4.5.2-0ubuntu2
运行在以下环境
系统 ubuntu_18.10 mercurial * Up to
(excluding)
4.5.2-0ubuntu2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-732 关键资源的不正确权限授予
阿里云安全产品覆盖情况