低危 Libgd 代码执行漏洞

CVE编号

CVE-2018-1000222

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-21
漏洞描述
Libgd 2.2.5版包含gdImageBmpPtr函数中的Double Free Vulnerability漏洞,该漏洞可导致远程执行代码。这种攻击似乎可以通过特制精制Jpeg图像进行攻击,可以触发double free攻击。在提交ac16bdf2d41724b5a65255d4c28fb0ec46bc42f5之后,此漏洞似乎已得到修复。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd 2.2.5 -
运行在以下环境
系统 alpine_3.10 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.11 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.12 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.13 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.14 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.15 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.16 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.5 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.6 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.7 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.8 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_3.9 gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 alpine_edge gd * Up to
(excluding)
2.2.5-r1
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 debian_9 gd * Up to
(excluding)
2.2.4-2+deb9u3
运行在以下环境
系统 fedora_27 gd * Up to
(excluding)
2.2.5-6.fc27
运行在以下环境
系统 fedora_28 gd * Up to
(excluding)
2.2.5-6.fc28
运行在以下环境
系统 fedora_32 gd * Up to
(excluding)
2.3.0-1.fc32
运行在以下环境
系统 opensuse_Leap_15.0 gd * Up to
(excluding)
2.2.5-lp150.3.3.1
运行在以下环境
系统 opensuse_Leap_42.3 gd * Up to
(excluding)
2.1.0-27.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-24.9
运行在以下环境
系统 suse_12_SP3 gd * Up to
(excluding)
2.1.0-24.9.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.10
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.10
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.10
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.10
运行在以下环境
系统 ubuntu_18.04 gd * Up to
(excluding)
2.2.5-4ubuntu0.2
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-415 双重释放
阿里云安全产品覆盖情况