低危 auth_handler.py中的身份验证绕过

CVE编号

CVE-2018-1000805

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-09
漏洞描述
Paramiko版本2.4.1,2.3.2,2.2.3,2.1.5,2.0.8,1.18.5,1.17.6在SSH服务器中包含一个不正确的访问控制漏洞,可能导致RCE。此攻击似乎可通过网络连接进行攻击。

解决建议

升级Paramiko到最新版本


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 paramiko paramiko 1.17.6 -
运行在以下环境
应用 paramiko paramiko 1.18.5 -
运行在以下环境
应用 paramiko paramiko 2.0.8 -
运行在以下环境
应用 paramiko paramiko 2.1.5 -
运行在以下环境
应用 paramiko paramiko 2.2.3 -
运行在以下环境
应用 paramiko paramiko 2.3.2 -
运行在以下环境
应用 paramiko paramiko 2.4.1 -
运行在以下环境
应用 redhat ansible_tower 3.3 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 alpine_3.11 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.12 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.13 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.14 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.15 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.6 paramiko * Up to
(excluding)
2.1.6-r0
运行在以下环境
系统 alpine_3.7 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_3.8 paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 alpine_edge paramiko * Up to
(excluding)
2.4.2-r0
运行在以下环境
系统 amazon_AMI paramiko * Up to
(excluding)
1.15.1-2.7.amzn1
运行在以下环境
系统 centos_6 paramiko * Up to
(excluding)
1.7.5-5.el6_10
运行在以下环境
系统 centos_7 paramiko * Up to
(excluding)
2.1.1-9.el7
运行在以下环境
系统 debian_8 paramiko * Up to
(excluding)
1.15.1-1+deb8u1
运行在以下环境
系统 debian_9 paramiko * Up to
(excluding)
2.0.0-1+deb9u1
运行在以下环境
系统 fedora_27 paramiko * Up to
(excluding)
2.3.3-1.fc27
运行在以下环境
系统 fedora_28 paramiko * Up to
(excluding)
2.4.2-1.fc28
运行在以下环境
系统 fedora_29 paramiko * Up to
(excluding)
2.4.2-1.fc29
运行在以下环境
系统 fedora_EPEL_7 paramiko * Up to
(excluding)
2.1.1-0.9.el7
运行在以下环境
系统 opensuse_Leap_15.0 paramiko * Up to
(excluding)
2.4.2-lp150.2.3.1
运行在以下环境
系统 oracle_6 paramiko * Up to
(excluding)
1.7.5-5.el6_10
运行在以下环境
系统 oracle_7 paramiko * Up to
(excluding)
2.1.1-9.el7
运行在以下环境
系统 ubuntu_14.04 paramiko * Up to
(excluding)
1.10.1-1git1ubuntu0.2
运行在以下环境
系统 ubuntu_16.04 paramiko * Up to
(excluding)
1.16.0-1ubuntu0.2
运行在以下环境
系统 ubuntu_18.04 paramiko * Up to
(excluding)
2.0.0-1ubuntu1.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-732 关键资源的不正确权限授予
阿里云安全产品覆盖情况