Grafana 5.2.4/5.3.0 Query Editor 跨站脚本攻击

CVE编号

CVE-2018-1000816

利用情况

暂无

补丁情况

N/A

披露时间

2018-12-21
漏洞描述
针对5.2.4和5.3.0的Grafana版本确认存在一个跨站点脚本(XSS)漏洞,它存在于影响数据库和石墨查询编辑器中,可能导致在受害者浏览器中运行任意js代码。通过身份验证的用户必须单击先前插入有效载荷的输入字段,此攻击似乎是可利用的。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 grafana grafana 5.2.4 -
运行在以下环境
应用 grafana grafana 5.3.0 -
CVSS3评分
5.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况