低危 SwCTBWrapper class 允许使用精心制作的文档拒绝服务

CVE编号

CVE-2018-10120

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-16
漏洞描述
在5.4.6.1之前的LibreOffice中的sw / source / filter / ww8 / ww8toolbar.cxx中的SwCTBWrapper :: Read函数以及6.0.2.1之前的6.x不验证自定义索引,该索引允许远程攻击者导致拒绝服务(具有写访问权限的基于堆的缓冲区溢出)或者可能通过包含特定Microsoft Word记录的精心设计的文档具有未指定的其他影响。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=017fcc2fcd00af17a97bd5463d89662404f57667
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * Up to
(excluding)
5.4.6.1
运行在以下环境
应用 libreoffice libreoffice * From
(including)
6.0.0
Up to
(excluding)
6.0.2.1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_7 libreoffice * Up to
(excluding)
1:3.5.4+dfsg2-0+deb7u11
运行在以下环境
系统 debian_8 libreoffice * Up to
(excluding)
1:4.3.3-2+deb8u2
运行在以下环境
系统 debian_9 libreoffice * Up to
(excluding)
1:5.2.7-1+deb9u4
运行在以下环境
系统 fedora_26 libreoffice * Up to
(excluding)
5.3.7.2-9.fc26
运行在以下环境
系统 opensuse_Leap_42.3 libreoffice * Up to
(excluding)
6.0.4.2-21.1
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 autocorr-af * Up to
(excluding)
1:5.3.6.1-19.el7
运行在以下环境
系统 sles_12 libreoffice * Up to
(excluding)
6.0.4.2-43.33
运行在以下环境
系统 sles_12_SP3 libreoffice * Up to
(excluding)
6.0.4.2-43.33.1
运行在以下环境
系统 suse_12_SP3 libreoffice * Up to
(excluding)
6.0.4.2-43.33.1
运行在以下环境
系统 ubuntu_14.04_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu5.5
运行在以下环境
系统 ubuntu_16.04 libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial6
运行在以下环境
系统 ubuntu_16.04_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial6
运行在以下环境
系统 ubuntu_18.04_lts libreoffice * Up to
(excluding)
1:6.0.3-0ubuntu1
运行在以下环境
系统 ubuntu_18.10 libreoffice * Up to
(excluding)
1:6.0.3-0ubuntu1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-129 对数组索引的验证不恰当
CWE-787 跨界内存写
阿里云安全产品覆盖情况