低危 systemd 竞争条件漏洞

CVE编号

CVE-2018-1049

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-17
漏洞描述
在234之前的systemd中,.mount和.automount单元之间存在竞争条件,使得来自内核的自动安装请求可能不被systemd服务,导致内核保持 mountpoint,并且尝试使用所述挂载的任何进程将挂起。这样的竞争条件可能会导致拒绝服务,直到卸载 mountpoint为止。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/systemd/systemd/commit/e7d54bf58789545a9eb0b3964233defa0b007318
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop systemd * Up to
(excluding)
234
运行在以下环境
系统 amazon_2 systemd * Up to
(excluding)
219-42.amzn2.7
运行在以下环境
系统 centos_7 systemd * Up to
(excluding)
219-42.el7_4.7
运行在以下环境
系统 debian_8 systemd * Up to
(excluding)
215-17+deb8u8
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u10
运行在以下环境
系统 opensuse_Leap_42.3 systemd * Up to
(excluding)
228-41.1
运行在以下环境
系统 oracle_7 systemd * Up to
(excluding)
219-42.0.2.el7_4.7
运行在以下环境
系统 redhat_7 libgudev1 * Up to
(excluding)
0:219-42.el7_4.7
运行在以下环境
系统 suse_12 libsystemd0-228 * Up to
(excluding)
150.29
运行在以下环境
系统 suse_12_SP2 systemd * Up to
(excluding)
228-150.29.1
运行在以下环境
系统 suse_12_SP3 systemd * Up to
(excluding)
228-150.29.1
运行在以下环境
系统 ubuntu_14.04 systemd * Up to
(excluding)
204-5ubuntu20.26
运行在以下环境
系统 ubuntu_14.04.6_lts systemd * Up to
(excluding)
204-5ubuntu20.26
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.1
运行在以下环境
系统 ubuntu_16.04.7_lts systemd * Up to
(excluding)
229-4ubuntu21.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况