低危 389-ds-base 1.4.x LDAP Search Filter LDAP Request Out-of-Bounds 拒绝服务漏洞

CVE编号

CVE-2018-1054

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-08
漏洞描述
在389-ds-base处理某些LDAP search filters的方式中发现了越界内存读取缺陷,影响了包括1.4.x在内的所有版本。远程未经身份验证的攻击者可能会利用此漏洞通过特制的LDAP请求使ns-slapd崩溃,从而导致拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
http://directory.fedoraproject.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject 389_directory_server * Up to
(including)
1.4.0.6
运行在以下环境
系统 amazon_2 389-ds-base * Up to
(excluding)
1.3.6.1-28.amzn2.0.1
运行在以下环境
系统 amazon_AMI 389-ds-base * Up to
(excluding)
1.3.6.1-28.54.amzn1
运行在以下环境
系统 centos_6 389-ds-base * Up to
(excluding)
1.2.11.15-94.el6_9
运行在以下环境
系统 centos_7 389-ds-base * Up to
(excluding)
1.3.6.1-28.el7_4
运行在以下环境
系统 debian_8 389-ds-base * Up to
(excluding)
1.3.3.5-4+deb8u1
运行在以下环境
系统 debian_9 389-ds-base * Up to
(excluding)
1.3.5.17-2
运行在以下环境
系统 fedora_26 389-ds-base * Up to
(excluding)
7.1.17-1.fc26
运行在以下环境
系统 fedora_27 389-ds-base * Up to
(excluding)
7.1.17-1.fc27
运行在以下环境
系统 fedora_28 389-ds-base * Up to
(excluding)
7.2.5-1.fc28
运行在以下环境
系统 opensuse_Leap_15.1 389-ds-base * Up to
(excluding)
5.4.0-lp151.5.6.1
运行在以下环境
系统 opensuse_Leap_15.2 389-ds-base * Up to
(excluding)
5.4.0-lp152.7.3.1
运行在以下环境
系统 opensuse_Leap_42.3 389-ds-base * Up to
(excluding)
7.0.7-37.2
运行在以下环境
系统 oracle_6 389-ds-base * Up to
(excluding)
1.2.11.15-94.el6_9
运行在以下环境
系统 oracle_7 389-ds-base * Up to
(excluding)
1.3.6.1-28.el7_4
运行在以下环境
系统 redhat_6 389-ds-base * Up to
(excluding)
0:1.2.11.15-94.el6_9
运行在以下环境
系统 redhat_7 389-ds-base * Up to
(excluding)
0:1.3.6.1-28.el7_4
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-48.el7
运行在以下环境
系统 suse_11_SP4 389-ds-base * Up to
(excluding)
5.3.17-112.23.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-109.27
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.25
运行在以下环境
系统 ubuntu_16.04_lts php7.0 * Up to
(excluding)
7.0.30-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 389-ds-base * Up to
(excluding)
1.3.7.10-1
运行在以下环境
系统 ubuntu_20.04 389-ds-base * Up to
(excluding)
1.4.1.5-1
运行在以下环境
系统 ubuntu_21.04 389-ds-base * Up to
(excluding)
1.4.1.5-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况