低危 load_cent()允许通过精心设计的ZIP文件进行拒绝服务或未指定的影响

CVE编号

CVE-2018-1056

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-28
漏洞描述
在2.1-2018 / 02处理ZIP文件处理之前,在advancecomp的方式中发现了一个越界堆缓冲区读取缺陷。攻击者可能会利用此漏洞通过欺骗它来处理制作的ZIP文件来使advzip实用程序崩溃。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://sourceforge.net/p/advancemame/bugs/259/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 advancemame advancecomp * Up to
(excluding)
2.1
运行在以下环境
系统 debian_7 advancecomp * Up to
(excluding)
1.15-1+deb7u1
运行在以下环境
系统 debian_8 advancecomp * Up to
(excluding)
1.19-1+deb8u1
运行在以下环境
系统 debian_9 advancecomp * Up to
(excluding)
1.20-1+deb9u1
运行在以下环境
系统 fedora_27 advancecomp * Up to
(excluding)
2.1-4.fc27
运行在以下环境
系统 fedora_28 advancecomp * Up to
(excluding)
2.1-4.fc28
运行在以下环境
系统 ubuntu_14.04.6_lts advancecomp * Up to
(excluding)
1.18-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04 advancecomp * Up to
(excluding)
1.20-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts advancecomp * Up to
(excluding)
1.20-1ubuntu0.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况