中危 POSTGRESQL <= 10 函数伪造可导致远程代码执行漏洞

CVE编号

CVE-2018-1058

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2018-03-03
漏洞描述
PostgreSQL是PostgreSQL开发组所研发的一套自由的对象关系型数据库管理系统。该系统支持大部分SQL标准并且提供了许多其他特性,例如外键、触发器、视图等。 PostgreSQL 9.3版本至10版本中存在安全漏洞。攻击者可利用该漏洞以超级用户的权限执行代码。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://www.postgresql.org/about/news/1834/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 postgresql postgresql * From
(including)
9.3
Up to
(including)
10.0
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
系统 alpine_3.10 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.11 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.12 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.13 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.14 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.15 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.4 postgresql * Up to
(excluding)
9.5.12-r0
运行在以下环境
系统 alpine_3.5 postgresql * Up to
(excluding)
9.6.8-r0
运行在以下环境
系统 alpine_3.6 postgresql * Up to
(excluding)
9.6.8-r0
运行在以下环境
系统 alpine_3.7 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.8 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_3.9 postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 alpine_edge postgresql * Up to
(excluding)
10.3-r0
运行在以下环境
系统 amazon linux_AMI postgresql * Up to
(excluding)
9.6.8-1.80.amzn1
运行在以下环境
系统 amazon_AMI postgresql * Up to
(excluding)
9.4.17-1.74.amzn1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 17.10 -
运行在以下环境
系统 debian_10 postgresql * Up to
(excluding)
6.1.5-3+deb10u7
运行在以下环境
系统 debian_11 postgresql * Up to
(excluding)
7.0.4-4
运行在以下环境
系统 debian_9 postgresql * Up to
(excluding)
9.6.8-0+deb9u1
运行在以下环境
系统 debian_sid postgresql * Up to
(excluding)
7.2.2-1
运行在以下环境
系统 fedora_27 postgresql * Up to
(excluding)
5.4.6.2-6.fc27
运行在以下环境
系统 fedora_28 postgresql * Up to
(excluding)
6.0.3.2-9.fc28
运行在以下环境
系统 opensuse_Leap_15.0 postgresql * Up to
(excluding)
6.1.3.2-lp150.2.6.2
运行在以下环境
系统 opensuse_Leap_42.3 postgresql * Up to
(excluding)
9.4.17-21.1
运行在以下环境
系统 redhat_7 autocorr-af * Up to
(excluding)
1:5.3.6.1-19.el7
运行在以下环境
系统 sles_11_SP4 postgresql * Up to
(excluding)
9.4.17-0.23.16.1
运行在以下环境
系统 sles_12 libecpg6 * Up to
(excluding)
9.6.8-3.16
运行在以下环境
系统 sles_12 libreoffice * Up to
(excluding)
6.0.5.2-43.38
运行在以下环境
系统 sles_12_SP2 postgresql * Up to
(excluding)
9.4.17-21.19.1
运行在以下环境
系统 sles_12_SP3 postgresql * Up to
(excluding)
9.6.8-3.16.1
运行在以下环境
系统 sles_12_SP4 postgresql * Up to
(excluding)
6.0.5.2-43.38.5
运行在以下环境
系统 suse_11_SP4 postgresql * Up to
(excluding)
9.4.17-0.23.16.1
运行在以下环境
系统 suse_12_SP2 postgresql * Up to
(excluding)
9.4.17-21.19.1
运行在以下环境
系统 suse_12_SP3 postgresql * Up to
(excluding)
9.6.8-3.16.1
运行在以下环境
系统 ubuntu_14.04 postgresql * Up to
(excluding)
9.3.22-0ubuntu0.14.04
运行在以下环境
系统 ubuntu_14.04_lts postgresql-9.3 * Up to
(excluding)
9.3.22-0ubuntu0.14.04
运行在以下环境
系统 ubuntu_16.04 postgresql * Up to
(excluding)
9.5.12-0ubuntu0.16.04
运行在以下环境
系统 ubuntu_18.04 postgresql * Up to
(excluding)
10.3-1
运行在以下环境
系统 ubuntu_18.10 postgresql-10 * Up to
(excluding)
10.3-1
阿里云评分
5.5
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况