低危 Python up to 2.7.14/3.4.8/3.5.5 pop3lib apop() 拒绝服务漏洞

CVE编号

CVE-2018-1060

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-19 03:29:00
漏洞描述
在python的pop3lib的apop()方法中实现catastrophic backtracking 的方式存在缺陷。攻击者可以使用此漏洞导致拒绝服务。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python * Up to
(excluding)
2.7.15
运行在以下环境
应用 python python * From
(including)
3.0
Up to
(excluding)
3.4.9
运行在以下环境
应用 python python * From
(including)
3.5.0
Up to
(including)
3.5.5
运行在以下环境
应用 python python * From
(excluding)
3.6.0
Up to
(including)
3.6.4
运行在以下环境
应用 python python * From
(including)
3.6.5
Up to
(excluding)
3.7.0
2
运行在以下环境
应用 redhat ansible_tower 3.3 -
3
运行在以下环境
系统 amazon_2 python * Up to
(excluding)
2.7.16-1.amzn2.0.1
4
运行在以下环境
系统 alpine_edge python * Up to
(excluding)
2.7.15-r0
5
运行在以下环境
系统 alpine_3.8 python * Up to
(excluding)
3.6.6-r0
6
运行在以下环境
系统 alpine_3.13 python * Up to
(excluding)
2.7.15-r0
7
运行在以下环境
系统 alpine_3.12 python * Up to
(excluding)
2.7.15-r0
8
运行在以下环境
系统 amazon_AMI python * Up to
(excluding)
2.7.15-1.124.amzn1
9
运行在以下环境
系统 alpine_3.5 python * Up to
(excluding)
3.5.6-r0
10
运行在以下环境
系统 alpine_3.7 python * Up to
(excluding)
2.7.15-r0
11
运行在以下环境
系统 alpine_3.6 python * Up to
(excluding)
2.7.15-r0
12
运行在以下环境
系统 debian_8 python * Up to
(excluding)
3.4.2-1+deb8u2
13
运行在以下环境
系统 debian_9 python * Up to
(excluding)
2.7.13-2+deb9u4
14
运行在以下环境
系统 alpine_3.9 python * Up to
(excluding)
2.7.15-r0
15
运行在以下环境
系统 alpine_3.10 python * Up to
(excluding)
2.7.15-r0
16
运行在以下环境
系统 alpine_3.11 python * Up to
(excluding)
2.7.15-r0
17
运行在以下环境
系统 suse_12_SP5 python * Up to
(excluding)
3.6.10-4.3.5
18
运行在以下环境
系统 fedora_27 python * Up to
(excluding)
3.5.6-1.fc27
19
运行在以下环境
系统 fedora_28 python * Up to
(excluding)
3.5.6-1.fc28
20
运行在以下环境
系统 fedora_30 python * Up to
(excluding)
3.5.7-1.fc30
21
运行在以下环境
系统 fedora_29 python * Up to
(excluding)
3.5.7-1.fc29
22
运行在以下环境
系统 suse_12_SP3 python * Up to
(excluding)
3.4.6-25.16.1
23
运行在以下环境
系统 oracle_7 python * Up to
(excluding)
2.7.5-76.0.1.el7
24
运行在以下环境
系统 suse_12_SP4 python * Up to
(excluding)
2.7.13-28.16.1
25
运行在以下环境
系统 fedora_EPEL_7 python * Up to
(excluding)
3.4.9-1.el7
26
运行在以下环境
系统 fedora_26 python * Up to
(excluding)
3.6.5-1.fc26
27
运行在以下环境
系统 opensuse_Leap_15.1 python * Up to
(excluding)
3.6.10-lp151.6.7.1
28
运行在以下环境
系统 opensuse_Leap_42.3 python * Up to
(excluding)
2.7.13-27.9.1
29
运行在以下环境
系统 suse_11_SP4 python * Up to
(excluding)
2.6.9-40.15.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况