低危 389-ds-base up to 1.3.8.2/1.4.0.9 Search race condition 拒绝服务漏洞

CVE编号

CVE-2018-10850

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-14 09:29:00
漏洞描述
在版本1.4.0.10之前的389-ds-base,1.3.8.3在389-ds-base处理持久搜索的方式中容易受到竞争条件的影响,如果服务器负载不足则导致崩溃。匿名攻击者可以利用此漏洞触发拒绝服务。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://pagure.io/389-ds-base/issue/49768
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject 389_directory_server * Up to
(excluding)
1.4.0.10
2
运行在以下环境
系统 debian_8 389-ds-base * Up to
(excluding)
1.3.3.5-4+deb8u1
3
运行在以下环境
系统 debian_9 389-ds-base * Up to
(excluding)
1.3.5.17-2
4
运行在以下环境
系统 amazon_AMI 389-ds-base * Up to
(excluding)
1.3.7.5-28.58.amzn1
5
运行在以下环境
系统 amazon_2 389-ds-base * Up to
(excluding)
1.3.7.5-28.amzn2.0.1
6
运行在以下环境
系统 opensuse_Leap_15.0 389-ds-base * Up to
(excluding)
1.4.0.3-lp150.3.3.1
7
运行在以下环境
系统 oracle_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
8
运行在以下环境
系统 centos_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况