低危 Samba客户端远程代码执行漏洞

CVE编号

CVE-2018-10858

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-23
漏洞描述
在samba客户端处理目录列表中超长文件名的方式中发现了堆缓冲区溢出。恶意的samba服务器可能会利用此缺陷在samba客户端上导致任意代码执行。 4.6.16、4.7.9和4.8.4之前的Samba版本容易受到攻击。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.samba.org/samba/security/CVE-2018-10858.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
应用 samba samba * Up to
(excluding)
4.6.16
运行在以下环境
应用 samba samba * From
(including)
4.7.0
Up to
(excluding)
4.7.9
运行在以下环境
应用 samba samba * From
(including)
4.8.0
Up to
(excluding)
4.8.4
运行在以下环境
系统 alpine_3.10 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.11 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.12 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.13 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.14 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.15 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.5 samba * Up to
(excluding)
4.5.16-r1
运行在以下环境
系统 alpine_3.6 samba * Up to
(excluding)
4.6.16-r0
运行在以下环境
系统 alpine_3.7 samba * Up to
(excluding)
4.7.6-r1
运行在以下环境
系统 alpine_3.8 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_3.9 samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 alpine_edge samba * Up to
(excluding)
4.8.4-r0
运行在以下环境
系统 amazon linux_2 samba * Up to
(excluding)
4.8.3-4.amzn2.0.1
运行在以下环境
系统 amazon linux_AMI samba * Up to
(excluding)
4.8.3-4.amzn1
运行在以下环境
系统 amazon_2 samba * Up to
(excluding)
4.8.3-4.amzn2.0.1
运行在以下环境
系统 amazon_AMI samba * Up to
(excluding)
4.8.3-4.amzn1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_8 samba * Up to
(excluding)
2:4.2.14+dfsg-0+deb8u13
运行在以下环境
系统 debian_9 samba * Up to
(excluding)
2:4.5.12+dfsg-2+deb9u3
运行在以下环境
系统 fedora_27 samba * Up to
(excluding)
4.7.9-0.fc27
运行在以下环境
系统 fedora_28 samba * Up to
(excluding)
1.4.0-3.fc28.1.3.5
运行在以下环境
系统 opensuse_Leap_15.0 samba * Up to
(excluding)
4.7.8
运行在以下环境
系统 opensuse_Leap_42.3 samba * Up to
(excluding)
4.6.14
运行在以下环境
系统 oracle linux_7 samba * Up to
(excluding)
4.8.3-4.el7
运行在以下环境
系统 oracle_7 samba * Up to
(excluding)
4.8.3-4.el7
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 ctdb * Up to
(excluding)
0:4.8.3-4.el7
运行在以下环境
系统 sles_11_SP4 samba * Up to
(excluding)
94.14.2
运行在以下环境
系统 sles_12 libdcerpc-binding0 * Up to
(excluding)
4.6.14+git.157.c2d53c2b191-3.29
运行在以下环境
系统 sles_12_SP3 samba * Up to
(excluding)
3.29.1
运行在以下环境
系统 suse_11_SP4 samba * Up to
(excluding)
94.14.2
运行在以下环境
系统 suse_12_SP3 samba * Up to
(excluding)
4.6.14
运行在以下环境
系统 ubuntu_14.04 samba * Up to
(excluding)
2:4.3.11+dfsg-0ubuntu0.14.04.16
运行在以下环境
系统 ubuntu_14.04_lts samba * Up to
(excluding)
2:4.3.11+dfsg-0ubuntu0.14.04.16
运行在以下环境
系统 ubuntu_16.04 samba * Up to
(excluding)
2:4.3.11+dfsg-0ubuntu0.16.04.15
运行在以下环境
系统 ubuntu_16.04_lts samba * Up to
(excluding)
2:4.3.11+dfsg-0ubuntu0.16.04.15
运行在以下环境
系统 ubuntu_18.04 samba * Up to
(excluding)
2:4.7.6+dfsg~ubuntu-0ubuntu2.2
运行在以下环境
系统 ubuntu_18.04_lts samba * Up to
(excluding)
2:4.7.6+dfsg~ubuntu-0ubuntu2.2
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况