低危 SPICE up to 0.14.0 Message 输入验证漏洞

CVE编号

CVE-2018-10873

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-18
漏洞描述
Red Hat SPICE是美国红帽(Red Hat)公司的一个企业虚拟化桌面版所使用的自适应远程呈现开源协议,它主要用于将用户与其虚拟桌面进行连接,能够提供与物理桌面完全相同的最终用户体验。 Red Hat SPICE 0.14.1之前版本中存在拒绝服务漏洞,该漏洞源于所生成的代码缺少充分的边界检测。攻击者可通过发送特制的信息利用该漏洞造成拒绝服务(崩溃)。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://gitlab.freedesktop.org/spice/spice-common/commit/bb15d4815ab586b4c4a20f4a565970a44824c42c
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
应用 spice_project spice * Up to
(excluding)
0.14.1
运行在以下环境
系统 alpine_3.10 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.11 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.12 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.13 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.14 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.15 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.16 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.5 spice * Up to
(excluding)
0.12.8-r4
运行在以下环境
系统 alpine_3.6 spice * Up to
(excluding)
0.13.3-r3
运行在以下环境
系统 alpine_3.7 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.8 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_3.9 spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 alpine_edge spice * Up to
(excluding)
0.14.1-r0
运行在以下环境
系统 centos_6 spice * Up to
(excluding)
0.26-8.el6_10.1
运行在以下环境
系统 centos_7 spice * Up to
(excluding)
0.34-3.el7_5.2
运行在以下环境
系统 debian_8 spice * Up to
(excluding)
0.25-1+deb8u1
运行在以下环境
系统 debian_9 spice * Up to
(excluding)
0.33-3.3+deb9u1
运行在以下环境
系统 opensuse_Leap_15.0 spice * Up to
(excluding)
0.14.0-lp150.3.3.1
运行在以下环境
系统 opensuse_Leap_42.3 spice * Up to
(excluding)
0.12.8-7.1
运行在以下环境
系统 oracle_6 spice * Up to
(excluding)
0.26-8.el6_10.1
运行在以下环境
系统 oracle_7 spice * Up to
(excluding)
0.14.0-2.0.2.el7_5.5
运行在以下环境
系统 redhat_6 spice-server * Up to
(excluding)
0:0.12.4-16.el6_10.1
运行在以下环境
系统 redhat_7 spice-glib * Up to
(excluding)
0:0.34-3.el7_5.2
运行在以下环境
系统 suse_11_SP4 spice * Up to
(excluding)
0.12.4-15.1
运行在以下环境
系统 suse_12 libspice-client-glib-2_0-8 * Up to
(excluding)
0.33-3.6
运行在以下环境
系统 suse_12_SP3 spice * Up to
(excluding)
0.12.8-6.1
运行在以下环境
系统 ubuntu_14.04 spice * Up to
(excluding)
0.12.4-0nocelt2ubuntu1.7
运行在以下环境
系统 ubuntu_14.04.6_lts spice * Up to
(excluding)
0.12.4-0nocelt2ubuntu1.7
运行在以下环境
系统 ubuntu_16.04 spice * Up to
(excluding)
0.12.10-1ubuntu0.2
运行在以下环境
系统 ubuntu_16.04.7_lts spice-protocol * Up to
(excluding)
0.12.10-1ubuntu0.2
运行在以下环境
系统 ubuntu_18.04 spice * Up to
(excluding)
0.14.0-1ubuntu2.2
运行在以下环境
系统 ubuntu_18.04.5_lts spice * Up to
(excluding)
0.14.0-1ubuntu2.2
运行在以下环境
系统 ubuntu_18.10 spice * Up to
(excluding)
0.14.0-1ubuntu4
运行在以下环境
系统 ubuntu_20.04 spice * Up to
(excluding)
0.14.0-1ubuntu4
运行在以下环境
系统 ubuntu_21.04 spice * Up to
(excluding)
0.14.0-1ubuntu4
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况