低危 正在从当前工作目录中读取ansible.cfg,允许可能的代码执行

CVE编号

CVE-2018-10875

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-14 11:29:00
漏洞描述
在ansible中发现了一个缺陷。从当前工作目录中读取ansible.cfg,可以将其更改为使其指向攻击者控制下的插件或模块路径,从而允许攻击者执行任意代码。<br>
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10875
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine 2.0 -
运行在以下环境
应用 redhat ansible_engine 2.4 -
运行在以下环境
应用 redhat ansible_engine 2.5 -
运行在以下环境
应用 redhat ansible_engine 2.6 -
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat gluster_storage 3.0.0 -
运行在以下环境
应用 redhat openshift 3.0 -
运行在以下环境
应用 redhat openstack 10 -
运行在以下环境
应用 redhat openstack 12 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
2
运行在以下环境
应用 suse package_hub - -
3
运行在以下环境
系统 opensuse_Leap_15.0 ansible * Up to
(excluding)
2.7.8-9.1
4
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.7.8-9.1
5
运行在以下环境
系统 debian_8 ansible * Up to
(excluding)
1.7.2+dfsg-2+deb8u2
6
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
7
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.6.3-r0
8
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.6.3-r0
9
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.6.3-r0
10
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.6.3-r0
11
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.6.3-r0
12
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.6.3-r0
13
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.6.1-1.el7
14
运行在以下环境
系统 fedora_27 ansible * Up to
(excluding)
2.6.1-1.fc27
15
运行在以下环境
系统 fedora_28 ansible * Up to
(excluding)
2.6.1-1.fc28
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-426 不可信的搜索路径
阿里云安全产品覆盖情况