低危 389-ds-base up to 1.3.6.14/1.3.8.0/1.4.0.8 ns-slapd LDAP Request 输入验证漏洞

CVE编号

CVE-2018-1089

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-10
漏洞描述
据发现,389-ds-base没有正确处理 long search filters ,其中字符需要转义,可能导致缓冲区溢出。远程未经身份验证的攻击者可能会利用此漏洞通过特制的LDAP请求使ns-slapd崩溃,从而导致拒绝服务。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
http://www.redhat.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject 389_directory_server * From
(including)
1.3.6.0
Up to
(excluding)
1.3.6.15
运行在以下环境
应用 fedoraproject 389_directory_server * From
(including)
1.4.0.0
Up to
(excluding)
1.4.0.9
运行在以下环境
应用 fedoraproject 389_directory_server 1.3.8.1 -
运行在以下环境
应用 fedoraproject 389_directory_server 1.3.8.2 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 moodle * Up to
(excluding)
19.4-7.1.al7
运行在以下环境
系统 amazon_2 moodle * Up to
(excluding)
0.35-4.amzn2
运行在以下环境
系统 amazon_AMI moodle * Up to
(excluding)
18.06.1ce-2.16.amzn1
运行在以下环境
系统 centos_6 moodle * Up to
(excluding)
1.2.11.15-95.el6_9
运行在以下环境
系统 centos_7 moodle * Up to
(excluding)
1.3.7.5-21.el7_5
运行在以下环境
系统 debian_10 moodle * Up to
(excluding)
0.35-2
运行在以下环境
系统 debian_11 moodle * Up to
(excluding)
0.38-2
运行在以下环境
系统 debian_8 moodle * Up to
(excluding)
1.3.3.5-4+deb8u1
运行在以下环境
系统 debian_9 moodle * Up to
(excluding)
1.3.5.17-2
运行在以下环境
系统 debian_sid moodle * Up to
(excluding)
0.38-2
运行在以下环境
系统 fedora_27 moodle * Up to
(excluding)
3.3.7-1.fc27
运行在以下环境
系统 fedora_28 moodle * Up to
(excluding)
3.4.4-1.fc28
运行在以下环境
系统 fedora_29 moodle * Up to
(excluding)
0.12.1-1.fc29
运行在以下环境
系统 fedora_EPEL_7 moodle * Up to
(excluding)
3.1.13-2.el7
运行在以下环境
系统 opensuse_Leap_15.0 moodle * Up to
(excluding)
1.4.1-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 moodle * Up to
(excluding)
19.03.1_ce-lp151.2.12.1
运行在以下环境
系统 opensuse_Leap_42.3 moodle * Up to
(excluding)
0.12.8-7.1
运行在以下环境
系统 oracle_6 moodle * Up to
(excluding)
1.2.11.15-95.el6_9
运行在以下环境
系统 oracle_7 moodle * Up to
(excluding)
19.4-7.0.3.el7
运行在以下环境
系统 oracle_8 moodle * Up to
(excluding)
19.4-11.0.1.el8
运行在以下环境
系统 suse_11_SP4 moodle * Up to
(excluding)
0.12.4-15.1
运行在以下环境
系统 suse_12_SP3 moodle * Up to
(excluding)
0.12.8-6.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况