低危 缓冲区溢出代码执行漏洞

CVE编号

CVE-2018-10907

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-05
漏洞描述
已经发现,由于server-rpc-fopc.c中的函数使用'alloca(3)分配固定大小的缓冲区,glusterfs服务器容易遭受基于多个堆栈的缓冲区溢出。经过身份验证的攻击者可以通过装入gluster卷并发送比固定缓冲区大小更长的字符串来利用此漏洞,从而导致崩溃或潜在的代码执行。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gluster glusterfs * From
(including)
3.12.0
Up to
(excluding)
3.12.14
运行在以下环境
应用 gluster glusterfs * From
(including)
4.1.0
Up to
(excluding)
4.1.4
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 debian_8 glusterfs * Up to
(excluding)
3.5.2-2+deb8u4
运行在以下环境
系统 debian_9 glusterfs * Up to
(excluding)
3.8.8-1+deb9u1
运行在以下环境
系统 fedora_27 glusterfs * Up to
(excluding)
3.12.14-1.fc27
运行在以下环境
系统 fedora_28 glusterfs * Up to
(excluding)
4.1.4-1.fc28
运行在以下环境
系统 fedora_29 glusterfs * Up to
(excluding)
4.1.4-1.fc29
运行在以下环境
系统 opensuse_Leap_15.1 glusterfs * Up to
(excluding)
3.12.15-lp151.3.3.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-121 栈缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况