低危 Linux kernel拒绝服务漏洞(CNVD-2018-07889)

CVE编号

CVE-2018-1091

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-28
漏洞描述
Linux kernel是一种计算机操作系统内核,以C语言和汇编语言写成,符合POSIX标准,按GNU通用公共许可证发行。 Linux kernel 4.13.5之前版本中的arch/powerpc/kernel/ptrace.c中的flush_tmregs_to_thread函数存在拒绝服务漏洞。该漏洞产生的原因是缺少处理器特性检查和核心转储路径中错误使用事务内存(TM)指令。攻击者可利用POWER主机上的核心转储期间的非特权用户空间利用该漏洞导致客户机内核崩溃。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/torvalds/linux/commit/c1fa0768a8713b135848f78fd43ffc208d8ded70
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon_2 linux * Up to
(excluding)
4.14.42-61.37.amzn2
运行在以下环境
系统 amazon_AMI linux * Up to
(excluding)
4.14.42-52.37.amzn1
运行在以下环境
系统 centos_7 linux * Up to
(excluding)
3.10.0-862.2.3.el7
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.65-1
运行在以下环境
系统 fedora_27 linux * Up to
(excluding)
3.12.14-1.fc27
运行在以下环境
系统 fedora_28 linux * Up to
(excluding)
4.1.4-1.fc28
运行在以下环境
系统 fedora_29 linux * Up to
(excluding)
4.1.4-1.fc29
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.13.4
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.7.8
运行在以下环境
系统 opensuse_Leap_15.1 linux * Up to
(excluding)
3.12.15-lp151.3.3.1
运行在以下环境
系统 opensuse_Leap_42.3 linux * Up to
(excluding)
4.4.126-48.1
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
3.10.0-862.2.3.el7
运行在以下环境
系统 redhat_6 glusterfs * Up to
(excluding)
0:3.12.2-18.el6
运行在以下环境
系统 redhat_7 bluez * Up to
(excluding)
0:5.44-6.el7
运行在以下环境
系统 redhat_7 glusterfs * Up to
(excluding)
0:3.12.2-18.el7
运行在以下环境
系统 redhat_7 kernel * Up to
(excluding)
0:3.10.0-862.2.3.el7
运行在以下环境
系统 redhat_7 lftp * Up to
(excluding)
0:4.4.8-12.el7
运行在以下环境
系统 redhat_7 postgresql * Up to
(excluding)
0:9.2.24-1.el7_5
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-94.41
运行在以下环境
系统 sles_12 lftp * Up to
(excluding)
4.7.4-3.6
运行在以下环境
系统 sles_12 libdcerpc-binding0 * Up to
(excluding)
4.10.5+git.129.35f7bb6e177-1
运行在以下环境
系统 sles_12 libdcerpc-binding0 * Up to
(excluding)
4.6.16+git.124.aee309c5c18-3.32
运行在以下环境
系统 sles_12 libecpg6 * Up to
(excluding)
10.5-1.3
运行在以下环境
系统 suse_12 libecpg6 * Up to
(excluding)
10.5-1.3
运行在以下环境
系统 suse_12_SP3 linux * Up to
(excluding)
4.4.126-94.22.1
运行在以下环境
系统 ubuntu_14.04.6_lts linux-azure * Up to
(excluding)
4.15.0-1023.24~14.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts linux-azure * Up to
(excluding)
4.13.0-1005.7
运行在以下环境
系统 ubuntu_18.04.5_lts samba * Up to
(excluding)
2:4.7.6+dfsg~ubuntu-0ubuntu2.2
运行在以下环境
系统 ubuntu_18.10 gnome-bluetooth * Up to
(excluding)
3.28.2-2
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况