低危 389 Directory Server ldapsearch 输入验证漏洞

CVE编号

CVE-2018-10935

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-12
漏洞描述
在389 Directory Server中发现了一个漏洞,它允许用户使用带服务器端排序的ldapsearch在LDAP服务器中导致崩溃。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10935
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon linux_2 389-ds-base * Up to
(excluding)
1.3.7.5-28.amzn2.0.1
运行在以下环境
系统 amazon linux_AMI 389-ds-base * Up to
(excluding)
1.3.7.5-28.58.amzn1
运行在以下环境
系统 amazon_2 389-ds-base * Up to
(excluding)
1.3.7.5-28.amzn2.0.1
运行在以下环境
系统 amazon_AMI 389-ds-base * Up to
(excluding)
1.3.7.5-28.58.amzn1
运行在以下环境
系统 centos_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
运行在以下环境
系统 debian_8 389-ds-base * Up to
(excluding)
1.3.3.5-4+deb8u1
运行在以下环境
系统 debian_9 389-ds-base * Up to
(excluding)
1.3.5.17-2
运行在以下环境
系统 opensuse_Leap_15.0 389-ds-base * Up to
(excluding)
1.4.0.3-lp150.3.3.1
运行在以下环境
系统 oracle linux_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
运行在以下环境
系统 oracle_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
运行在以下环境
系统 redhat 389_directory_server * From
(including)
1.3.0.0
Up to
(excluding)
1.3.8.7
运行在以下环境
系统 redhat 389_directory_server * From
(including)
1.4.0.0
Up to
(excluding)
1.4.0.14
运行在以下环境
系统 redhat_7 389-ds-base * Up to
(excluding)
0:1.3.7.5-28.el7_5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况